OSX 10.6.2 32bit Blender 3D Alpha 1

Ok so maybe I’m dumb, but is there no build for this, it’s not on the official Blender.org site and I can’t find one that will work on graphicall.org. Can someone help me out here.

Why do you want to use a 32 bits build rather than a 64 bits???
Since Leopard, OSX can easely handdle 64 bits at least as well as 32 bits programs… So why 32?!?
On MacPro there no significant difference runnig one or the other.
Have you tried the last 64bits yet?

What’s wrong with the Mac OS X 10.4, 32 bit version on blender.org ?


He’s not writing about the 10.4.x (Tiger) version, Richard. mofx has the 10.6.2 (the one is useless i install because of obsolete GC!). It’s totally 64bits compatible (at the least).
With 10.6.2, i deffinitely would suggest to use the 64bits bulids whatsoever. :yes:

If you really want 32bit blender that 10.4 version does work in OSX 10.6.x just like the 64bit version is for 10.5, but I agree go with 64bit


They reason I don’t run 64 is because I don’t know if my other programs will run in it. But I did just restart in 64bit and it still doesn’t work and neither does the 10.4 in 32bit. So it seems I have a bigger issue I need to deal with. Thanks for the advice though.

I don’t know since how long you are used with OSX… But: you DON’T have to restart in 64bits mode to use the 2.51 OSX 64bits builds. :no:
Just leave Leopard as it is and run the 64 bits version. No other tweaks, here. :smiley:

Really, hmm. Well none of the builds are working for me. So I need to figure out what’s wrong, Blender 2.5 alpha works but nothing newer than that. Any thoughts?

I have the same problem. The Terminal tells me that there is a “segmentation fault”. There is a bug some place??? Something missing??? If you find a build that runs let me know.

I’m running 2.5 32bit and 64bit versions on Snowleopard without problems.
If you have tried an earlier 2.5 version before, you could try to delete the .B25.blend file in your User folder.
This makes problems sometimes between the alpha versions.
To delete the hidden file, you can use the terminal or the hiddenfiles widget
Or you can use the blender 2.49 filebrowser, selecting the file and deleting with the r or the x key.


Eh? There are no “32bit and 64bit versions” of 10.6. Snow Leopard (10.6) simply runs both 32 and 64 bit apps. People must be used to Windows where you need to choose the correct OS edition.

However, you need 64 bit capable Mac to run 64 bit apps, which means a Core 2 Duo or above. Any Mac less than roughly three years old is 64bit capable.

Normally, download the file - most of the builds have files in a file, with the app file amongst them - under this form i rename the main file (repertory) usually simply adding the svn number and rename the Blender.app the same way. After that i make an alias of the app. I then pull the complete repertory into Applications and the alias into my Doc repertory dedicated to 3D apps.
Clicking on an alias opens as many Blender versions the machine can manage.
Never no problem - first opening gives you an alert message about an app being downloaded from the web - that’s it.

Nobody said there are 32bit and 64bit versions of Snow Leopard.
I said I’m running 32bit and 64bit versions of blender 2.5 ON Snowleopard without problem.
But this is maybe bad english?


Patel, Nice that worked like a charm, thanks man.

Thank you Patel so very much. Everything is good now.

my 2.5 blender version work fine except for when playing with objects my cursor goes crazy, it flicker and jitter, i get to cursor and it is hard to do minor adjustments , i can use the pallets to do so , but i curious if anyone knows how to fix that.

i am using imac with snow leopard and i thin 1.6.2 version.