OSX users, can you render Particle Systems?

I had first problems with hair particle systems, it worked when it was one instance, then I duplicated it and it couldn’t be rendered anymore w/o crash.

now I have two PA systems settings, emetting random obj from two groups. and it crashes.

is there anyone that can render PA systems on OSX?

Could you share your blend?
I can test it.

of course …

http://www.pasteall.org/blend/3364

Crashes when press render using the official 2.53beta, OSX 10.6.4

I also have problem doing fluid simulations, there’s no visible frame-by-frame change when I bake it. and the progress bar nothing happens but If I wait, and just press alt+A to play animation it’s done a fluid sim actually.

how’s that for the rest of you on mac, btw I have window draw to automatic, and VBO’s turned on.

crashes for me under Win7 64 bit build 31038

Dave

@richard

I got the very latest from GA.org, r31194 I already bug tracked it. my previous hair bug, didn’t show up on ubuntu. I suspect fluid sim, and this PA sys also to work prop. on linux. :S

Assertion failed: (node->cut_cost[0] != INFINITY), function calc_costs, file source/blender/render/intern/raytrace/reorganize.h, line 501.

I’m trying to turn on instances in performance tab under rendering button menu. since I have several instances of the particles. hum.

by default it’s “Auto” on “Acceleration Structure”, but if I choose “BLI BVH”, it doesn’t crash immediately. it gets stuck on the Occl. Pre-processing…

but nothing happens.

It crashes here too with tkroo’ latest build!
I dont wanna be offense, but how the hell they have produced sintel with blender 2.53 !!!???
So many crashes.
I burning to make some productions with blender 2.53. But crashes alot.

OK it’s not OS specific then.

I had an suspision it had to do with the raytracing going havoc, a ray going for infinity or something. (I don’t know form the error log but it looks like that)

So I tried rendering with the render branch but it still crashes.

I did render with OpenGL from the viewport, and it works. so it’s not the simulation that breaks.

It has to do with Indirect Lightning AND particle systems. because indirect lightning works well if I just had the meshes sitting there.

so beats me, there’s a bug report on it, if I now could search my report I could update it with this.

Hey! I had some problems with particles too. I’ve tested a lot of different settings to solve the render problem and I found the bug.
I’m on the OS X 10.6.4 with the build 31209.
You can’t modify the “Rotation” panel settings in some cases with object instances or group as particles, you can adjust just the rotation mode (Normal, Velocity, Object X Y Z …), if you modify the Random values, Spin values or any other rotation value the blender crash when render. In some cases you need to set the cache step to 1.
I know nothing about the code or the system behind the particles or raytracing, but there’s a bug around the Instance particles with rotation values changed. I don’t know exactly where is the bug or what is it, but I solved this problem using the default values in particles rotation panel.
Test it in your systems:
http://www.pasteall.org/blend/3370

Anyone?
Somebody tested?

Eversimo, yours works with the last tkroo build.

I hey guys i need help too.
I cant export a uv-map out of Blender.
I got exported sucessfully exported a png file, but its blank. No wires to see.
Here is the file:
http://www.pasteall.org/blend/3388

Oh holy sh#t, @everismo it worked! what a weird bug, I updated my bugreport and made it across all platforms also.

In the image editor window use UVs / Export UV Layout. In the browser window that opens up, select the format from the drop down box on the left hand side (.svg or .eps)

@tungee

do as Richard says, export as .svg it worked for me. import in PS or Gimp and you should see them. IMO vectorized is better than png, cleaner, scalable and easier to work with.

Ok many Thanx, Aermartin and Richard.
I will try, but is it a bug?:confused:
In 2.49 , i can swear the exported thing was a png (rasta-image):eek:

Ok, i found two problems:
1.Gsgl preview is painfully slow (1024* 1024)!
2.Where comes the wireframe rendering?? ihavent checked this!

Here is the blend-file (image couldnt be packed:no: also):
http://www.pasteall.org/blend/3396

uv picture:
http://www.pasteall.org/pic/5117

http://img828.imageshack.us/img828/8357/uvtestrender.png

rasterized image, yes it was. and that was no good ;D haha. The vector is better believe me. It changed in 2.5

dude! the wireframe is most likely you forgetting to hide that layer in your texture editor :stuck_out_tongue_winking_eye: check that first, or flatten the image before exporting it, so you dont use a source file with several layers, maybe blender reads the file wrong and shows hidden layers.

but first, make sure you dont have the UV islands .svg/.eps layer turned on above your actual texture layer :stuck_out_tongue_winking_eye: