"Out of Memory" on 32gb ram, I9 900K and GTX 1070

Hi lovely Blender community,
I see other people have posted about problems like this, and I’ve read them, but their answers didn’t work at all for me.
A little bit of history: I’ve had these kinds of problems before with blender and currently have a third where no matter the settings, the GPU is barely used. (And I really do doubt it’s a cpu bottleneck causing it).
I’m currently under the “Updating Lights | Computing Distribution” part of the render running face-first into this “Out of Memory” wall that doesn’t budge at all.

It’s a high-density city scene, we’re talking about 9m tris and 4.5m verts. But, I’ve rendered stuff like this before on the very same system.

Win 10
I9 9900K
32 gb RAM
Nvidia GTX 1070

What I’ve tried:
Camera culling (scene -> simplify)
Max subdivisions.
CUDA, Optix, None. (Preferences -> system)
Making ABSOLUTELY SURE it was changed to GPU in Scene.
Disabling all subdivisions
Cutting all lighting sources by 50% (changing to non-emissive materials)
Closing Chrome (and other background stuff - I got annoyed)
Lowering Sample counts
Changing to different deniosers (I’ve had blender crash due to 1070 having problems with Optix before)
Disabling Volumetrics (Had a volume in there)
Updating gfx drivers (Multiple times)

It’s a very large scene and usually, it takes a while to get going, but here it just cuts out 20 seconds in.

I’m at a loss here guys. Wtf is going on…

Does it work as a CPU render, and if so how much memory does it report using?

No. It chokes at the same point. For memory usage I’ve got a couple of different readings.
All structures rendered: 29 gb ( +8 gb vram)
One structure rendered: 8-9 gb. ( +2.7 gb vram)
*these are hooked up on a particle system using children already to reduce memory costs. 400 parents, 10 children.

Which is what really bothers me. Why does it pass out at 9 gb when it has already proven to be able to utilise all available 29? (+ 8 gb vram)

Is it a .blend you can share so we can poke at it? It sounds like you have one or more features that are just exploding memory requirements. I have a 16GB ram, RTX2070 system I could try it on. You didn’t say which version of Blender, have you tried more than one?

For denoise, I think it’s a lot faster if you use the OIDN Compositor Denoise node as a post-process and it has no additional impact on the main render (apart from possibly computing the Denoise Passes if you want the most accuracy.

Here’s a WeShare link since “new users can’t upload files” - weird: https://we.tl/t-pilgjFPcaH
I’m currently using blender version 2.90.
About denoising, well… it’d be wonderful if it’d actually get that far. But, it gives up wayyy before. I’m just making sure I’m either using none or one that doesn’t make my blender crash of odd reasons.
Also, I’ve ordered an RTX 3080, but I have this sneaking suspicion that this isn’t about my system and it’s resources, but Blender and how I’ve unknowing messed something up VERY badly…

I got it to render, but. no subdivision. I had the particles set to 0.1… just 10% and it still took 20gb of memory.

I think you need to optimize the scene. A lot.

I just looked at your particle system and it seems it is wrong. It renders hundreds of the same objects in the same place.

The whole scene is just a mess. It also runs out of memory with 128GB RAM.