Outlaw's Skins sketchbook

A sketchbook to track my progress creating a better skin.

Base image:

Result of node adjustments:

Result of node adjustments minus scene lighting and BG object.


AAAAND I’m done.

Result of node setup/conclusion:


Double Post

Reworked nodes with exact render settings as previous “vanilla” image.


Reworked nodes with 750 AA samples.

Layers broken down


Single Light Scatter



Normal Map Nodes

Displacement + Micro Displacement

Deep Layer SSS

Combined SSS

ooooo…it’s like adding layers of skin…

Mixed feelings.
Early renders show incredible brightness. Is small possibility that false light is screwing up SSS.
Waiting for high sample render to complete.
Reduced Spec.

Muted Spec

MicroSpec w/ displace. low samples

All nodes added together. Still incredibly bright.

Possible to remove spec?
Looked okay before added spec maps.
Will still wait for final render before evaluation.

Color loss/detail loss
Lips are too pale.
Normals are too frequent.
Again “pixelated” shadows.
looks like face is made of rough sand paper.
Maybe adjust normal scale…

Node setup 2; variation 1

Plugged grayscale into new SSS layer.
Removed SPEC. map.
Rearranged SSS layers.
Normal map assigned to diffuse texture.
Mixed feelings about result.
Normals still obviously tiled. Maybe mixing with displacement map will matter. Would like to randomize normals…
Specularity finally applying correctly. Pale skin can be found on high points of face and skin that is under direct light.
SSS working correctly. Diffuse details have finally returned.
Side note: did not seem to matter what order SSS layers were added in; the result was always the same. Yet, removing one of the layers would result in obvious difference. (IE: removing deep SSS layer would make pale white the predominant color. Removing mid sss layer resulted in detail loss and red skin).
Need to experiment with Displacement and work on the normals. Also: try moving lights around to fix those shadows.

Note: Shadows unfixable. Cycles devs. said “not a bug”. Increase poly of model/adjust lighting to correct.

The pixelated shadows are from having too small a res. Just increase subdivide by one or two times and it’ll be totally gone. It’s a very stupid way that blender calculates shadows of round objects.
Otherwise keep it up, you’re not finished here but please push yourself to finish this properly for the sake of learning properly.


Then again, maybe not.
Playing around with shadows settings yielded less than desirable results. Exasperated, turned shadows off, rendered face with terrible dark artifacts. Turned shadows back on and this was the result:

Never in a million years would have thought “Try turning it off and then back on again” would actually work.

Nice right? Well, in the midst of playing with the shadows settings, I must have been rummaging around in the “normals” settings as well, for they are not exactly present here. Further review shows that they have been disconnected from 2nd application of diffuse shader. Result is lacking primary focus, but looks good. Possibility exists that “normals” are causing degradation of shadows.
On to test 213.

Yes. My post directly before yours was about a forum post I found @ blender.org regarding this issue. They call it the “Terminator Effect” and most render engines experience it. Adding poly doesn’t help, but removing the normals does…more experimentation is required.