Outliner All Collection Folders Open When Saved All Closed

Hello, this is pretty minor, but very bothersome. I have many collections in my outliner and close them all adn save the file, quit blender. Upon starting up blender and opening the file every one has the triangle turned down showing every object in every collection and I have to constantly close them all one by one so I can navigate everything easier.

Is there a setting in prefs to fix this or a way to prevent them from constantly opening? I tried holding Shift to close them all at once, but that just seems to further expand the nested folders and then you have to click it again to then close that one specific folder, no way of closing them all at once that I can find. Then do the same thing on the next folder, and the next and the next. Its really time consuming when having to bounce back and fourth between different blender files with so many collections in each.

Am I missing something obvious to fix this? It seems like a but that I save the file with them all closed, then they are all open when reopening the file.

Thanks for any help!


Hello. This behavior is caused because you have your Load UI setting disabled in your Users Preferences. When disabled, Blender uses default UI settings on startup.

1 Like

Thank you very much, that was indeed the “issue”. I had that turned off because opening older scenes from past versions was so different (I have saved custom layout tabs at the top to bounce around) looking with the UI changes I would forget how to get to what I was used to seeing and where.

Thank you!

You’re welcome, glad I could help. :slightly_smiling_face:

You know that you can explicitly turn Load UI of while loading an older file by using the cogwheel/gear icon :gear: on the right in the Blender File View ?

1 Like

I do, and thank you for the reply. The issue I was having was that I wouldn’t know what version of blender some of my older scenes were made in and I wouldn’t know until I opened them and saw an outdated GUI. I would also often forget to check the cog wheel option and all in all, it was just more streamlined to turn it off.

But, not I will have to get back in the habit of check it when I think I’m opening an older file.

Thank you!