Overlapping alpha channels not working

Does anyone know how to get two objects with alpha channels that overlap to work?
I always have issues with either it being totally transparent where it shouldn’tAlphaTest-PAK01.blend (2.55 MB) be or opaque.


Material settings:
Transparency: z transparency, specular alpha 0
Then either Shadows -> view transparent, or make them shadeless if that is the desired effect

If you then wonder where the light color around the blue asterix comes from, it comes from the image itself. It has the blue color surrounded by full white, very light blue, and teal colors, and the alpha channel doesn’t mask those out. The last group of 6 toggles on the uv/image editor header has 3 options to show the image: with alpha, colors without alpha, and alpha channel only. That could be changed in couple of ways

One is to edit the image and use the original alpha as a mask and have the colors go way past the current areas, or


could do the same with the texture setup. Colors are defined in the first texture and the original is only used for the alpha.

Use “Z transparency” transparency type with no speculer value in Blender internal material settings.

Edit ^

Thanks guys.
Can this also be done with nodes?

Yes


Left: light edges, Right: result from shown nodes.

Enabling nodes reveals another panel in material properties, render pipeline options, which might not have transparency set by default.

Changing the borders with nodes should be possible also. Probably could use texture nodes to change the texture itself, bring the texture in material nodes, colorize them based on the material alpha, or other creative options. In the screenshot the colors are replaced by the UV position.

Thanks again.
Next question, if I turn on cycles render, the objects turn black.
Why is that?

Blender Render and Cycles are completely different render engines, and their material systems aren’t compatible.

Ok, I didn’t realize that.
Is there any way to get a node set up for cycles that does the same thing?
Make the transparency work with cycles?

Yes, easily.

But this jumping from one question to another makes me wonder if I’m wasting my time, and by answering with yet another node setup also waste yours. Changing from one render engine to another has implications, it’s not just better to switch to Cycles because a popular tutor said it’s better.

Switching the render engines changes the viewport display capabilities, and Cycles is using global illumination by default. That means that it’s not enough for you to just get the materials in, you also need to change the render settings so it doesn’t do calculations that aren’t actually needed. What you are showing is basically flat colors against a background. If that’s all you render, rendering with Cycles could be the worst option to choose because it’s the slowest, especially with the default settings.

There is a third option: if you can make the viewport show what you need, you can capture that with opengl render image/animation (from render menu or the header). The chosen render engine would affect what can be shown in the viewport, but it wouldn’t be used for getting the images out. This was “rendered” with that technique https://www.youtube.com/watch?v=lqiN98z6Dak


The equivalent node setup for Cycles and optimized render settings.

Sorry, I’m not trying to waste your time. I was using a simplistic approach to try and achieve this:


I can make the muscle objects glow using cycles but can’t figure out how to make the node also work for the alpha channels.
Where the objects overlap I have a complete transparency or black.
Google search wasn’t helping so I took some steps back to try and see if I could do it step by step.
Any help would be appreciated.
That video made me a bit ill by the way, I’ll never reach that point.

Well, I figured it out!
There was nothing wrong with the nodes. After many hours of trying all sorts of things I deleted the objects I was having problems with and placed new ones in. It worked.
Now I have to figure out how to stretch an object wile it’s animated.