Overlapping Image Textures - Alpha Artifacts

Hello!
I’m trying to apply image textures with alpha transparencies to simple plane meshes, so that I can overlap/animate them. I’ve searched for the answer but can’t seem to find it.

There are basically 3 issues as seen in the below images:

  1. the shape of the mesh plane is actually what casts a shadow, not the shape of the alpha transparency.
  2. The white logo is actually in front, but all overlapping areas disappear; turning the Zoffs to 0 seems to help (second image) but not sure why
  3. Part of the plane mesh is reflecting a highlight, even though the alpha value is set to zero.

The image textures have these settings: UseAlpha, Clip
Map Input: Orco, Flat
Map To: Col, Alpha (clicked once)
DVar: 1.0
Material: Alpha 0
Render Pipeline: ZTransp, Zoffs: 0

Any insights are appreciated:)

http://www.yourmomlikesmywork.com/images/00-temp/111808-test.jpg

http://www.yourmomlikesmywork.com/images/00-temp/111808-test2.jpg

I believe you have to turn on the TraShadow button on each plane that is going to recieve the shadows.

Thanks, Atom.
I’m on the right track! Now those crazy plane highlights…

http://judahsst.dot5hosting.com//images/00-temp/111808-test3.jpg

Ok, I just turned the Spec way down, it seems to have done the trick!