'P' closes Blender in Ubuntu OS :: [SOLUTION IN THREAD]

When I press “P” blender just closes. I’m useing the Linux-686 Ubuntu (Gnome) on a P3 pc with an Nvidia graphics card. I’ve tryed uninstalling Blender and then re installing it and it still does it. I’ve heard of others have a similar prob and that it was easy to fix… I just forgot where I heard it and how to do it.

Thanks,
AHDRL

Hello
start blender from the console or an xterm, ex:
type /pathtoyourblenderdirectory/blender -w
and look the messages warnings ( if any)
Bye

I’ve seen the same problem. I haven’t managed to fix it, but I can tell you its a segmentation fault.

Blender 2.42, Ubuntu Edgy, Nvidia with driver from repository. Pressing ‘P’ does what it should do. What are your specs? :slight_smile:

Try installing sdl-dev from synaptic.

For the game engine to run under Ubuntu you have to have a bunch of SDL files installed, as fireside said, I think its the libsdl-dev you need.

libsld-dev is the development package for sdl. so you need it if you are compiling from source.

so, to fix the problem, we need error message, some sort.

does this happen when you hit alt-a in blender aswell?
does sound work?

.b

libsld-dev is the development package for sdl. so you need it if you are compiling from source.

That’s what you would think, but apparently there is a file in the dependencies that it needs or something. It won’t run on my computer with Ubuntu unless I install the sdl-dev from synaptic.

basse; Alt-a does not close Blender. It runs a very small blackbox on the curser with running numbers. Sound is weird in this with some things I have it with others it doesnt seam to be there (I had probs with windows and sound also, different but still problems).

skypa; Mine is Ubuntu Dapper with the synaptic list Blender2.41 that is curently available (2.42 hasn’t made it to synaptic yet). I had to get my Nvidia drivers from the Nvidia site (They have some for Ubuntu).

fireside and kit89; I put both ‘sdl-dev’ and ‘libsdl-dev’ into the search field of synaptic and it showed no responses (I have all the universes and areas enabled).
Where do you get these?

plantperson; umm … What Is a “segmentation problem”? and how would I know if I had one? Also, what would I do about it if I had one?

Otto; I’ve enjoyed your tutorials. (I strugle with them a little though).
Hmmm… I don’t think I know how to find the “path to my blender file”. I tryed to hunt it down but I dont even know which file to look in. could you give me a pointer or two?

Thanks folks,
AHDRL

Just type “sdl” in the search box. You’ll get a long list. The file you want is libsdl1.2-dev.

Otto; I’ve enjoyed your tutorials. (I strugle with them a little though).
Hmmm… I don’t think I know how to find the “path to my blender file”. I tryed to hunt it down but I dont even know which file to look in. could you give me a pointer or two?

open a terminal, and type this:

find / | grep blender

to explain in 2 lines, the command find searches your root directory tree (/) and passes (|) the results to the grep command, which in turn locates anything with “blender” in it. This will show you the path where your blender executable file is, probably something like /usr/local/bin/blender or /usr/bin/blender.

But normally your blender executable is in a directory which is searched automatically (those “bin” directories), so instead of doing /path/to/your/blender -w, you can probably just do blender -w
This will run blender in window mode, instead of full-screen. On the terminal, where you just typed blender -w, blender will put all its error messages. So, if the problem happen again, the blender window will close but maybe it will print some useful error message before… You tell us

All right! Progress…
Otto and Yorik; “find / | grep blender” gave me a huge list of files, :cool: cool but useless to me at this moment.
However, “blender -w” opened the window with Blender in it. (I always seam to expect things to be really complicated when they’re not. *Lol a little at self), this is what came out of that when I pressed “p” in my .blend project;

Using Python version 2.4
Unable to load: libtiff.
Try setting the BF_TIFF_LIB environment variable if you want this support.
Example: setenv BF_TIFF_LIB /usr/lib/libtiff.so
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
/usr/bin/blender: line 46: 14514 Segmentation fault      blender-bin [email protected]

Do I just need to install “libtiff” or is there something else that this is saying to me? (I have no idea how to set “…the BF_TIFF_LIB environment variable” either).

Fireside; I found the “libsdl1.2-dev” thing just as you said and am about to install it. (I wanted to see the error messages and post them first). I’ll let you all know if that makes a difference in a moment…
doing that now on a different desktop (I love this Ubuntu!)
… It Worked! I have the game playing umm… “P” function, Thanks!
(Ubuntu should realy put that library in the Blender package automaticly).

Now, did this include “libtiff” or do I still need that?

Thanks for your patience with this, all of you.
AHDRL

Hello again
Yorik have made a correct answer, well explained, but I’m too lazy :frowning:
Thank you for the comments about the tuts…they’re hard?
I don’t have much feedback on them, but probably I don’t explain enough
for begginers!?
Don’t bother much with libttif, if not installed you don’t have TIFF suport ( can’t
save TIFF images for ex. )
Bye

Thanks Otto,
I think I may install that suport for TIFF, (always good to have a variety at hand) thanks for telling me what it is.
And; No, your Tutorials are not to hard, I learn a lot from them. I have a ‘little otto’ waiting for bones at this very moment. I got sidetract on texturing him in GIMP, (thats a lot of fun!), which I really didn’t know very well… Soo, I’m learning that also.
My problem is a combination of ‘biting off to many mouthfulls at once’, and, ‘old “dog” new tricks’ syndrome. Many of you younger people are realy fast at this and you have my respect.

(lol, notice how I ignore the fact that many people my age [46, just had a b-day Oct 4] are really good at these things too. Ya, well, I do have an ego to take care of.)

Thanks again, all of you.
AHDRL