Pagination oddity

Using ‘New Posts’, the bottom of the list shows ‘Results 1 to 99 of 110’. Clicking on Page 2 icon (or next page arrow) gives me ‘No matches. Please try some different terms’.
page 1:

page 2:

Using Chromium 60.0.3112.78 on Debian 4.9.0-3 amd64.

firefox 55.0 i only have one page, 1-10 results.

Must be a permissions thing of some sort. Added to the to-investigate list :slight_smile:

I don’t know vBulletin, but pagination is typically hidden in the infrastructure as a simple DB lookup with an offset and limit — you just have to specify paginate in increments of 100 rows and you’re done. I noticed that I can search on a term guaranteed to return lots of items (e.g., “model”) and pagination works as expected.

I would not call this high priority. I’ll just try to keep up better. :smiley:

Check now and see if the issue is resolved for you.

Hmm. I’ve been keeping up so haven’t gone into a second page BUT a list of new posts just showed me “1 to 36 of 37” which didn’t make any sense.

@fweeb Just now: showing 94 of 107, page 2 is empty.

how are you getting so many under “New Posts”? I got displaying 1-6 of 6.

I put off reading the forum for a day. It’s a challenge, but I actually put it off an entire day.

So strange. I still can’t reproduce. Are you running any extensions in your browser?

I have always had this issue (on Mac Safari) and I also reported it; in my experience until it overcomes 120 entries there is no chance to see the threads on the second page. And even with less than 100 I get sometimes wrong numbering such as ‘7 0f 9’.

a small correction, right now I get ‘102 of 102’ with the last two on the second page; so the issue is occasional, although very frequent.


An RSS reader. Stock theme. Maybe an ad blocker (on an Android pad right now.) I’ll try to reproduce this on the pad this week.

@fweeb: This appears to be mostly working.

I Just got back from a week’s vacation and the “New Posts” first page showed “1 - 100 of 500”, 2nd page was “101 - 200 of 446”, and the remaining were similar with the last one as “401 - 446 of 446”.

Whew… It appear that clearing the caches have at least helped in one place. :slight_smile:

So, solved?

Yes. I thought as author I could mark it solved myself but didn’t find anything in thread tools, FAQ, or a search.

You do it by editing your top post in Advanced mode. You can change the prefix there.



I think I ran into the issue too.