Paint Layer Manager issues

I have some issues. Im trying out the Paint Layer Manager add-on. Im doing currently tattos on my character. So I added a colour map from the menu and when I paint I have
the result in the 2-nd picture.

However when I render I get this weird looking distortion on the mesh as you can see in the 1-st image. Anyone that happen to have the same issue or know a solution.
Just to mention the character has a normal map baked previously without using the addon.

http://memberfiles.freewebs.com/35/10/84161035/photos/Test-Renders/Tattoo1.jpg

http://memberfiles.freewebs.com/35/10/84161035/photos/Test-Renders/Tattoo.jpg

That’s a problem of how unintuitive Blender can be sometime, you need the following extra steps

-Once you have painted your color map layer, go to the UV\Image Editor

-In the list of texture you have, select your Color map that is automatically created when you clicked on the Add Color in the “Add paint Layer” tab of the N menu when you were in Texture Paint mode.
http://i.imgur.com/5p5ft.jpg

-Look meanwhile in the Texture tab there, as it where you’ll see how clunky Blender can be :
http://i.imgur.com/ykxsl.jpg

  • Now back to the UV\Image Editor, then click on Image -> Save As Image , save it in the format you want, by example PNG

-Once saved, look again at the texture tab
http://i.imgur.com/SDi09.jpg

  • See now what i mean, you had to do the previous step so suddenly the actual option need to solve the problem you see in the rendering only appear now. Those required option only appear when the texture exist as a file, not if they only exist in Blender.

Enable then this “Premultiply” button that appeared and it will render without the white artifact.

Very infromative man. Thank you. And from what I heard this add-on kinda suffers from some kind of issues, although I find it to be a very powerfull tool(if working correctly). Gonna try this asap.

I don’t think this specific bug is related to the paint layer addon, because even without it, just creating a new texture in Blender UV\Image editor, when adding this texture to a material, the missing options i mentionned are always missing and if you have alpha , you’ll see then the same white artifact when rendering (as the premultiply option is missing).

So lesson learned is that we must save our newly created texture before anything else, so all the correct options appear where they should.

I wanted to report that some time ago on the bug tracker, but noticed that it was reported in summer 2011 (phrased differently but from the attached screenshot on that report, it’s about the same problem)
http://projects.blender.org/tracker/?group_id=9&atid=498&func=detail&aid=27892

As half a year after it’s always there, i can only guess that the development focus of the devs dedicaced to the render have been on Cycles, Blender Internal related problem may probably have taken a backseat unfortunately.

So… with or without an add-on, every time I…

Unwrap>>Add image

… I should save the added image right away before any work has been done to it. Interesting.

This in general sounds like a smart practise to follow, and actualy Im doing this every time I work with stencil maps.

BUT…I will agree with you and say that I have been using Blender for the last 3 and something months and texturing has to be the most disorganized and unintuitive aspect of the whole program.