Painted Strokes Failing to Show Up and Synchronize Between Views

I have run into an issue with texture painting in Blender that is making it near impossible to use, and I’m not sure what I’m doing wrong or missing.

Overview of the issue:

I’ve got a basic crate created and set up with a UV mapping and basic material that allowed me to start texture painting with the 3D Viewport in Texture Paint mode on one side and the Image Editor in Paint view on the other side of the Blender window.

I was able to successfully paint in either view as desired on screen with the paint strokes showing up in real time in both views for a bit. Soon it just stopped showing the strokes in the view I was painting in (Image Editor more commonly), while still showing said stroke in the other window (i.e. I’d paint something in the Image Editor window with no visible change, but the 3D Viewport would show the stroke normally).

When these failures to synchronize occurred, I had not made any changes to Node selections or changed any checkboxes anywhere. At first I’d only even done basic things like change the brush color / size, hit Ctrl + S to save, hit Ctrl + Z to undo, zoomed in/out with the middle mouse wheel, and tilted and panned with the middle mouse wheel (with Shift as appropriate).

The issue has occurred both on my laptop without a Cintiq attached and later with the tablet (I wanted to try using the Cintiq for painting). Also, I’m using Blender v3.4.1.

Things I’ve tried:

Since I’m new to Blender, I’ve done some searching to see if I could find anyone else describing this issue, and so far, nothing I’ve found has quite matched or worked when I’ve tried the suggested results anyway.

To give a general rundown of all the things I have tried:

  • Swapping to a different workflow tab at the top, such as Layout. This worked a couple of times then stopped. Occasionally will help, but rarely.
  • Restricting to only one view window at a time (i.e. only 3D or only Image Editor). Also worked briefly and then not at all.
  • Opening a New Window through the main Window menu. Worked briefly then stopped.
  • Once I added the Cintiq, I tried using Blender both with the main window on the laptop, on the Cintiq, and with the display just being duplicated between the laptop and Cintiq. All such changes helped briefly and eventually stopped.
  • Closing and reopening the file. Works briefly then stops.
  • Closing and reopening Blender. Works and then stops.
  • Clicking the checkbox for Automatically Pack Resources in the External Data section of the File Menu. Worked once.
  • Saved the UV based Image as a different file name from the one originally created (using Save As). Worked once.
  • Clicked the Backface Culling option both on and off. Worked once for each then swapping either direction did nothing to resolve the synching error.
  • Checked to make sure that the proper nodes seemed to be selected while in both views. That has never changed, so never actually helped and trying to swap to something else (like selecting UV Grid) and then swapping back did not correct the issue.

I’m at a point now where I really can’t paint with any consistency on the crate at all, even after completely closing and relaunching Blender. I have only turned on Node Wrangler manually, so the only other AddOns that are turned on are ones that started with installation.

I really want to be able to just paint this crate, but I feel stuck. It’s entirely possible that I’m missing something really basic, and if so I apologize. I just can’t seem to find an answer that permanently solves my issue rather than just a temporary fix that buys me sometimes as little as 5 minutes of painting before I can no longer see the stroke I just painted in the view I’m in. Before coming here I finally hit a point where I cannot seem to get a stroke to show up in either view anymore, so I’m hoping maybe someone will have an idea for me.

Thank you for your time in reading this.