painting on an object

Is there a way to paint a design or logo onto the surface of an object?

Yes, several. For a “decal” type effect, you use an empty, and make the empty have the image, then position it, z axis out on the mesh.

For “painting” you have to unwrap it. Look for a UV Unwrapping tutorial, there are several.

Is there any way to paint inside blender, without havign to take it into photoshop? As it is I don’t know the exact position of the decal so I have to unwrap it, bring it into photoshop, test it and then do it again. Is there a better way?

By the way this is what I am trying to do: paint the moons onto the tent instead of having them as separate objects. This is the pic:

/uploads/default/original/3X/e/0/e0d4dbc716f749d6d24fe4bfdb01a4be91cdedd6.jpgd=1163020877

You can use the texture paint mode after you have unwrapped the model with uv face select. The trick is to assign a blank image to the mesh in the uv image editor, then go into texture paint mode in your 3d view port. It’s a little tricky, but you can paint reference marks onto the model, then finesse it in your favorite image editor. Saxofoner’s advice is true - you will need to reference a uv tutorial, preferably from ibiblio.org where Greybeard has some wonderful references.
The controls for the texture paint are okay, but you probably won’t want to use them alone.
Craigo:)

Can we use verse to actively update a texture from Gimp to Blender? I often like to see the result immediately and hate the Blender standard paint tools.

I am painting on my unwrapped object, but when I preview it in the UV face select window, the image only appears on the inside

The “interior” pic is of the painting seen through the object.
The “exterior” pic is of the front where you can’t see the moons at all.

What causes this? It doesn’t happen on any test objects I have worked with.

Attachments



:eek: Ye!! I have the exact same problem and I don’t know how to resolve it. Ive set up a topic regarding my dilemma and no one has answered http://blenderartists.org/forum/showthread.php?t=82096

So could someone please tell us how to sort this out!?

Unless I am mistaken, your normals are facing inside, they need to be facing outside. Select all vertices and hit Control + N.

And if that isn’t it, try clicking double sided in the UV panel options.

Thanks a lot mate! Much appreciated.

awesome, thanks