Painting Textures in Blender and Gimp

Hi. I have a question: how to texture a Blender mesh properly (with multiple textures). I have unwrapped the UV’s, brought them in Gimp, and placed an image over. I got a very low resolution on the model. If I try to make the texture a pattern, then use the clone tool to paint it, again, low resolution. If I scale down the image, I don’t know how to crop it to fit the UV shell I want. How to texture a mesh and how to blend textures? How this thing is done properly, in industry, for example? How 3D objects are textured? I have searched over the internet, but couldn’t find a tutorial that could explain me. Could you help me please?

Found a tutorial . Does the same technique work in Gimp? Is there any way to crop faster?

Not working as it should. I can’t delete the texture scraps. Also, scaling and rotating is not working right.

Is not working right in Blender or in Gimp?

Also the process of texturing in Maya is not the same in Blender, you should check videos about texturing in blender (here’s a complete one, although instead of Gimp he uses Photoshop).

The problem is in Gimp. Unfortunately, I do not have Photoshop. In Blender, everything works ok. I get the UV snapshot exported.

Your beginning texture image size should be about 2048x2048 on a decent mesh object for painting so you can get details in resolution that looks good. Some people go as far as 4k textures for each object. I have a few videos on my youtube channel about texturing in blender and maybe some of that might help with the preparation stage before going to gimp. If you want another option for painting textures, you might try Krita if you are on Windows or linux, it is very good for painting.

Here is my pipeline from that tutorial, and the problem:

  1. I export the UV snapshot from Blender and load it in Gimp. 2. I load a texture image in a new layer, let’s say a wooden texture. 3. I place the image above a desired UV shell. 4. I select the UV snapshot layer, then with the magic wand selection tool, I select the region outside the shells. 5. With the selection active, I select the texture layer then press delete. 6. The texture outside the shells get deleted. However, the texture covers some unwanted shells, resulting some texture scraps. 7. With the rectangle sellection box and the texture layer selected, I select the scraps then press delete. The problem is that nothing happens.
    Hope it is clearer.

Pictures would help, screenshots. I don’t use magic wands for selection, I use a polygon lasso or standard lasso, and I don’t delete anything usually, I use layer masks and paint stuff out, and export a final image for my texture.

Sounds like user error. Are you sure you have selected the layer that contains what you are trying to delete?
You can post the gimp xcf file if you like and Ill have a look at it.

Well…I have tried again, and the box selection could be deleted. Probably that was an unexpected behaviour. Still, I remember, before that happened, there were also some weird things. Firstly, I couldn’t scale the images/layers by click and drag. At first, scale worked properly. After a few images loaded, every time I clicked the scale button, the scale dialog box appeared, instead of handles. Secondly, after deleting some image rests, instead of alpha background, it appeared white. I have tried texturing again a file for test, and got these errors. I have posted a screenshot, and also a link to the XCF file.

Those layers that have a white background don’t have an alpha channel. Right click on the layer and select add alpha channel.
Many of those layers are smaller than the image itself. Not a problem but you can’t add/remove stuff outside from that area. Right click on the layer and choose layer to image size if needed.

If you select the scale tool, you also have to click on the layer to show the handles. This is not the same as right clicking on layer and choosing scale layer. It’s also different from image menu -> scale image, and layer menu -> scale layer.

What you probably want to avoid is having texture end where the UV edge is. This will result to lines on the model because of mipmapping. Make textures go over the UV edges. There is space for that, and you don’t have to be as precise with the selection.

Adding an alpha channel before cropping works. Still, scaling is not working as it should.

What should I try next?

Click Ctrl-Shift-A before you scale - there is selection outside layer area.

This seems to solve the problem. Thanks.
In an upper post, Craig Jones said that he uses layer masks to paint stuff out. Do you know a tutorial on how to use layer masks for texturing ?

Idea is simple, uses are endless.
You know about layers and layer operations - all this Add, Multiply, Dodge, Burn etc stuff.
Have one layer as a basis, another - e.g. you want set to Multiply. What you do not want is to Multiply on all image - this is where you use layer mask - gray-scale mask, saying where you want Multiply to occur.

Have UV layout, color part done and want some grainy stuff to be over just one part of UVs - make selection, add layer mask to the layer with grunge. Adjust overall percentage of grunge layer and paint layer masks b/w values to modify influence further.

More or less here

Thanks a lot everyone.

Layer Masks are awesome.
I have just one more question for now:
Let’s say I load an image on a layer(a tree trunk texture), I duplicate that layer and move that image down, so they would be one image above another, to fill in the tree trunk shell. Between the two images, there is a seam. What is the best way to remove it? I have tried the clone tool, healing brush tool but didn’t get perfect results. I have even tried to use resynthesizer plugins, but it gave worse results. How do you clean up seams properly?
I have tried to apply make seamless filter, but I can’t match perfectly the images one beside another so there would still be a seam.

Try using Blender for that :wink:
And two more videos done a bit differently -
Ancient one, however contains quite a bits