Pan doesn't work on magic mouse using OS even when editing in user preference

Hi there,

I am currently having a problem with “pan” not working at all in blender.

Some context: I am using a laptop and a magic mouse (Not ideal, but this is what it is)
I have set up my magic mouse in user settings, and the following functions that most people have a problem with are working fine.

The following functionality is working for me:

Enable ‘Emulate 3 button Mouse’ option in the User Preferences / Input settings

Alt+LMB = Rotate
Ctrl+Alt+LMB = Zoom

I have read a thread on here that suggested changing the command to "Shift+Alt+LMB = Pan" but it doesn't work, and in fact nothing works when you change the command keys in user settings.

If anyone could help, that’d be great, until then I can’t do anything. :frowning:
Thanks for your help. :slight_smile: