Paper simulation - is cloth the right one for it?

Hello all blender Champions!

I’m trying to make simmilar paper simulation like on animation below:

OnRobot animation

Unfotunatelly I’m not even close to it… those are my results:


I was trying with many cloth settings, reduced thickness outher to minumum… but without sucess.Therefore I’m not sure if i use the right physic for this task.

I have also found some information, that the size of the object matters in that type of animation (bigger object = better resuls). Is it true? Below is a result with bigger paper sheet (2m x 2m) and it looks much better. Do i really need to scale my all scene to get a proper result?

Hi Tomasz,

No, you don’t need to scale everything up.
As with all physics sims, be sure to reset the scale on the ‘paper’ and collision meshes to 1.0 ( CTRL-a . . . apply scale ).

Here I have a 30cm by 20 cm sheet being moved:

The most important parameter to change on the cloth sim panel is the ‘bending model’ :- set it to linear ( it’s angular by default . . . which is better for cloth).

You’ll then need to tweak the bending parameters to ‘stiffen’ the paper, and be sure to turn down the vetex mass. These are the settings I used:

on the collision objects set the Thickness Outer to 0.001

and 'ere be the blend file ( you’ll need to re-simulate ).
Paper.blend (841.0 KB)

Cheers,
Dj.

1 Like

Hi DJ!

Thank you a lot for all advices. With similar settings like yours (only Vertex Mass is different: 0,001 kg => 0,005 kg), in empty blend file, I have got quite good result:

But when I copied it to my scene and baked again, I got something like this (with exactly the same settings, I dont’ even made child of constrain in empty to connect it to the gripper):

I checked colision settings in other objects, applied scale everywhere around, but still can’t get nice result in full scene.

The workaround for it is to bake it in “fake” blend file, and then copy it baked to the full scene. But is it really common pratcice in blender physics animations?

Hmm, if it works as intended in your test file, then there must be something extra happening in your final scene. This is what I would do in these circumstances:

Make a copy of your project file and use it to do the following . . .

DELETE EVERYTHING except the paper sheet. Do a simulation. If is fails then the problem MAY exist in the parameters of the paper ( also check you haven’t enabled a’ force’ - wind/turbulence etc) - go to number 3.

  1. If however it works, then the problem is in the other geometry . . . so, reopen the file and this time delete everything except for the robot arm, paper tray, orange boxes and the paper sheet. Try the sim.

  2. If a sim still fails, delete the robot arm. Try again. If that fails, delete the paper tray. If that fails delete the orange boxes.

By this point you should only have the single sheet of paper in the scene. If the sim fails now then there is a something else going on…

  1. Time to get drastic. . . Reverse you appending - so instead of merging the paper into the robot scene, merge the robot scene into the paper scene, but do it in stages, so that you can re-sim between each append and hopefully clear the bad behaviour. If this all works, then there was probably some corrupted data in the original file that was not being cleared.

  2. If all this fails, I’d need to look at the file myself to see what’s going on.

Cheers,
Dj.

1 Like

Hi DJ!

unfortunately only drastic methods worked… but at least it now looks like I wanted it to be. Below the final animation:

I was trying to find the root cause by copying elements part by part but without success. When I copied all elements the animation still looked ok.

Maybe the stack of paper made by geometry node was guilty (with colission turned on) … or maybe my lack of knowledge - that is my first bigger scene in blender :slight_smile:

Nevertheless it works and I want to thank you for your help DJ! The topic is solved now! :slight_smile:

1 Like