parenting mesh to bones makes hideous result

Howdy to all

The project I’m making is a skeleton with skin above it. I now have an arm bones done and I imported an arm from make human. To make it all move I have an armature that is already conected to the modeled bones and it works fine.

When I try to parent the imported mesh it deforms it and makes it quite hideous, why? WHy is it deforming the mesh instead of just parenting?

thanks for your help

I am not sure i get what the problem is, a blend file would really help to understand, or a image of the oddity.

Is it possible that you selected “create fron envelopes” when you did the parent? If so, try using “don’t create groups”.

Why are you parenting the mesh to the armature? You should just use an armature modifier on the mesh (Make sure to turn off envelopes on that as well).

In my newbish way I always just parented the mesh to the armature for rigging and then cleaned up the vertex groups.

I will try with an armature modifier and post back results, and I’ll take a screenshot for those who want to see.

Here’s a screenshot. So I have my armature, the bones of the hand and my skin mesh, I’m trying to parent both the bones of the hand and the skin mesh to my armature. As you can see from the screenshot, the thumb vertex group has been assigned to my armatures and has deformed! WHY?


Looks like there is something in the rig that might be not right. some constrain or something.
Is the problem still there if you put the armature in Rest position!?


I am guessing you have the skeleton ready and weightpainted, and nothing is wrong with it.
Try deleting every vertex group from the skin.
Then if you parent the armature to the skin without making any vertex groups nothing should happen.
Then use the bone weight copy script from the skeleton to the skin to get the vertex groups alike, it should work.

Other than that I am not sure…

I got that when I selected the “Create from Envelopes” option on parenting a mesh to an already posed armature. “Create from Bone Heat” option seems to create less problems.


There second idea would probably work, however I have done any weight painting, and I don’t know how to do it. How do I get the “Bone weight copy script”??


Whether using from envelopes or from bone heat I get the same result, this is using vertex group names and I assign the vertices myself and it still does this weird thing

But maybe it’s because the weight paint is done well… hmmm… I’ll be back

If you had used any other option other than “Don’t create groups” when parenting the mesh to the armature, chances are the blender has automatically assigned the vertexes of the now-distorted part to a nearby bone that you never wanted. To see which bone was assigned the vertexes:

  1. Select the mesh
  2. Change the view to the “Weight Paint” mode.
  3. In a “Button Window” select “Editing” mode (F9)
  4. In the “Vertex Group” box under the “Link and Materials,” Try selecting each vertex group name that is identical to the name of a nearby (or every) bone one by one, and see if the distorted part of the thumb in the “Weight Paint” view turns red. If it does, delete the corresponding vertexes from that vertex group.

I am pretty sure bone weight copy is standard.
make sure the hand have no vertex groups, just delete them all.
Select the bones and the hand and under “Object>script” you should have bone weight copy.
I use this script allot and it has made my life a bit easier.

well after a lot of trying, nothing, still gives me the same problem. It is exactly same the same effect weither parenting the armature or using the bone weight copy script… anyone else have any ideas?

post a .blend file

it’s 36 mb… but I’ll try

nope too big…

I’ve been getting rid of old data and things that have nothing to do with the problem and got it down to 7.9 mb… still too big :frowning:

victory… here’s the blend

I tried to use my own mesh for the skin, instead of the makehuman mesh, and it had the same effect??? WHy??