Particals system problem - looks like parts of the simulation are skipped

Hi there,
I have a problem with my particle system. At a certain point, the particles will skip a lot of frames. It looks like a part of the simulation has been cut away. Even if I delete the bake, change parameters and bake again, the same thing happens. What can be the reason?


I could’ not get it solved but when i copied my my meshes to a new file and then recreated the partical system with the exact same parameters it worked. So it seems lkike it had been a bug.

I think the issue your running into is that the cache got corrupted. This is a common problem (in my experience) with blender physics. What I do, before rendering, is to always bake the simulation externally. So its on disk and I know that if I load that and play it, the simulation will run correctly. This means that nomatter what, as long as I load the cache from disk I get the same result.

Did you clear the cache? I mean the colored line in the Timeline. Clear that by changing a setting (like particle number).
That will fix many problems.

I thought changin the parameter would help, but that did not work, but now i found a diffrent solutions that works. Clicking once on that icon with the dot and the round arrow around it in the cache section got everything fine. Its the Active Point Cache Index button.

1 Like