Particle animation and raytracing

How do I get particles to appear in raytracing? For example, if the particles pass behind a glass object, they will not appear, while the scenery behind the particles can still be seen. It’s like the particles can’t be detected by raytracing… does anyone have a solution?

Please be more specific. Do you mean dupliverted particles or halo paricles?

Asuming you mean halo particles, the answer is that halos are inserted at render time in a seperate pass, and since they are not actual objects, they aren’t detected by raytracing. So, there is no solution.

Dupliverted particles work just fine w/ raytraced objects, and they even work in YAFRay.


If dupliverted particles means particles emitted from an object’s vertexes, then that is what I’m talking about. They just don’t appear in the render (yes, I do have raytracing turned on)

Dupliverted particles means using objects in place of the particles (as in NOT using halos).

Halos won’t show in raytracing.


I think you are misunderstanding me.

Halo Particles- The default particles. The material color influences a blob that can be changed using the Halo option. Each halo coresponds to one particle. It’s what is used for making fire, smoke, fireworks, fur, grass, etc…

Dupliverted Particles- You make the emittor the parent of an object, and switch on the dupliverts option in the animation settings panel. This causes a copy of the object that is the child of the emittor to replace the standard “halo particle”.


Is there any plan to implement halos with raytracing?

This would be VERY VERY useful.

Does this mean you could make something like a model of…errr…an eyeball for example, then when you make it the child of the emitter, the emitter will then spit out eyeballs?

yes :slight_smile: