Particle emission density depending on video texture mask (only one frame)


I am trying to make a plane emit particles from areas that I can control by animating a bitmap mask.

There is a “movie” source option in texture menu, but using it will hang on the first frame of the video while the particle generation plays. I have set the frame range and offset already (250 for 10 seconds, offset 0 and start 1).

I don’t think you can change density per frame like this… you can test it by simply setting density to #frame and see if it works. My guess is it won’t.
If it does, do you have auto refresh checked on the video texture?

I didn’t, but nothing changed after turning it on.

I’m not sure where you mean I should put #frame; I am using the non-node texture window because I don’t really understand the texture node editor (I’m okay with material nodes). Putting frame number sync into the density setting in the influence menu… well, just checking if that’s what you meant?

Smoke seems to work in real time, but the texture seems to be scaled up significantly. I noticed this before, but it disappeared when I wasn’t paying attention. Any idea why that would occur and how to fix?