Particle emit between frames?

Suppose I have a rocket flying away and want it to emit gas as it flies off - it travels significant distance between frames, and so particles clump at its position at each frame - is there a way I can make it emit between frames - so I see a more consistent glas flow stream?


It is hard to say without seeing your particle setup, but you try changing the Cache Step from 10 to 1.


no, cache step is set to 1, the image shows my particle setup. I thought “Subframes” would do it, but that made no difference

Just bumping this thread because I’ve been having the exact same problem. Look at this video: http://www.youtube.com/watch?v=G7LcD8FYGm0
This is the smooth, connected particle stream we’re wanting to make behind a high-speed object.

Do you use a curve or path for the movement of the emitter? Did you parent it to a bone or something? Because in those cases clumping occurs. It’s a confirmend bug, will probably be fixed once paged particles hit trunk.

Until then use the technique from this tutorial for the animation of the emitter: http://blenderdiplom.com/index.php?option=com_k2&view=item&id=29:tutorial-light-streaks-in-blender&Itemid=106

The Motion Paths add-on looks neat, but since it can’t be used on bones its uses are few. Plus, even with non-armatures, the object clearly doesn’t follow the rotation as it would with a path object and “follow curve” enabled. It won’t drive a car, it won’t fly a rigged rocket man, but maybe it will shoot a bazooka, which is all I need at the moment.

For all those uses particles are clumping atm so you will need to wait until the bug is fixed…