Particle Emitter Visibility Problem

Hello all, another materials question…

Im running blender 2.66 r54977

I have an object with a material applied and I’m adding a particle system to it. When rendered, the emitter disappears despite having the checkbox to render the emitter checked. Could someone look at my blend file and see if there’s something i’m doing wrong?

I have tried checking and unchecking the emitter box and also changing the visibility of the particle system in the modifiers panel. when the particle system is invisible, the emitter renders but, obviously no particles render.

I kinda think this is related to my current build but not entirely sure.


Well, I have 2.66 revision ‘54747’ and it renders part of your scene like so. Is there something wrong with it? I can see the emitter.

Actually, there is an emitter on the ears and head also. Are you able to see those when it’s rendered?;

So it appears that it was a problem in that particular build. I tried a few different builds and the emitter does show in those. Thanks.

I had another look at your file this evening. It did not render the dupli objects on the head and the ears. I assigned completely new particle settings and it rendered them fine. I compared your settings to my new settings and made them completely identical. It still rendered mine but not yours. I deleted your settings and reapplied your them - unaltered - it rendered emitter and particles with your settings

That’s strange!

That is strange. I wonder what that’s all about? Thanks for your efforts! I built a new version of blender today and it seems to be working for me also. It would seem there’s some bug in there somewhere.