Particle hair coming through buttons problem

I’m using a method to make hair on fabric from a tutorial here: http://cgcookie.com/blender/2012/11/29/creating-a-little-elephant-character-in-blender-part-02/ How do I prevent the hair from going through the buttons? It’s not coming through the nose button because I made some mistake in the texture under it that seems to prevent the hair from growing from that area.

This image shows what I mean:

Link to my blend file:
http://www.pasteall.org/blend/19685

A few things come to mind:

  1. You could weight paint the teddy bear, this gives you the option to have the hair denser in certain areas, or no hair in certain areas. By default when you weight paint, a vertex group called ‘group’ is formed, you can rename it or just use it as named in the part. system under vertex groups->density.
  2. If you just want a binary hair/no hair solution you could create a vertex group that includes all of the vertices except those under the buttons. Again set the part. systems to the vertex group density.
  3. You could go into particle mode and ‘cut’ the hairs under the buttons. If you free edit later though those hairs will come back.

I used the weight paint method successfully. Thanks. I wanted to try the particle mode to cut the hair. But nothing seems to get cut. I’ve only used particle mode once before and I have no idea how it works. I remember there was a way to limit the number of hairs showing to start with, but I forgot how that works.
Anyway, thanks for telling me about the weight painting-vertex group method. I’m not too familiar with that either, obviously.

This is my teddy bear in particle mode.

Well for starters I think you have the hair length way to high. Default is 4 which is really long, probably for teddy bear fur you want something closer to .4 to .1, depending on the scale of the bear. And the ‘Number’ control how many parent hairs there are. You can keep this number lower (ballpark 300-1000) and then use children hairs to fill it out without hosing your machine.

I think what is happening is that when you cut the hairs in particle mode there are others that are so long (coming from farther away) that it appears that they are coming out of the button area. When you shorten the length it will become much clearer. Note once you go into particle mode and comb/cut etc… you can no longer adjust much of the particle system and you’ll need to click ‘free edit’ to get back to where you can modify the hair properties (length, number). Once you click free edit you’ll lose any styling you did in particle mode. Good luck, let me know if you have any questions.

Hi, perhaps you have already solved it yourself, because you mentioned to successfully weight painted it? I reply because your particel editing screenshot still shows some “weirdness” ;-).

I opened the file you provided, and looked at your setup. It’s a nice modeling and pretty well done seams! I have not worked with the new cycles hair particles until now but I’m happy that the most settings have remained the same.

First of all, you had 50K particles, so either you have a monster machine or plenty of time :wink: For my test I changed that to 1000 particles and 150 children per each particle. That is more memory efficient. As blenderallday said: The defaut length of 4 is way to long. So I set that to 0.06. Your metric system is set to “none”, so we mesure in blender units. That will perhaps have an effect when it comes to rendering (thickness of the hairs).

After that I created a vertex group “all” for your teddy bear went to weight painting. I lowered the weight around the eyes.


This weight painted vertex group is now the definition for the length in the particle system.


E voila - after all it’s fun!


BTW: I practiced the hair particles a lot with blender internal, and especially the lighting was something to get headaches from. Let’s hope that this will be much easier with cycles.

Perhaps you show your results in the focused critique?

I appreciate your detailed response. Unfortunately, due to my limited ability I can’t follow clearly all what you’re saying. In the tutorial, he uses cycles and says something about particle hair not working in Cycles, so he doesn’t use paths. He shows how to make a single hair with a bezier curve and uses it as an object in the particle hair system. So I assume I can’t go into particle mode to cut the hair. Anyway, I did end up making a vertex group. See screen shot below. It would have been better if I could have gotten closer around the eyes (like shown in your screen shot.) Still, there is so much else wrong with my final result, it’s not worth spending any more time on it. I could think of at least five questions I’d like to ask about this project (unrelated to the particle system), but I don’t want to get too bogged down on any one detail.

This is the second tutorial I’ve done from two different Blender tutors where they use the hair particle system and magically don’t cover the eyes. The tutorials don’t mention anything about vertex groups or particle mode to cut the hair.

This shows I did get rid of most of the hair going through the button eyes using weight painting and a vertex group.

Well the latest blender releases can render hair in cycles, but you have to enable experimental, instead of supported, in the render settings. I think your problem is that the bears head is really low poly (not a bad thing) and the quads near the buttons don’t match the topology of the buttons. So any vertex groups or weight painting are going to be either be too large or too small. You might need to create a couple more verts on the bears face under the buttons (but on the bear) and change the topology a little to better match the circular shape of the buttons. Or I suppose you could just cut them in particle mode. Looks really good though.

Ok, I see. But initial support for hair rendering was added in the brand new release of blender 2.66. So using a dupli object as a work around should no longer be necessary. See http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.66/Cycles

I re-uploaded the .blend file here , so you can see, what I changed in my version. (I played a little bit with the materials, because the textures were missing.) As I said: I used the hair particles and not the method of duplicating an object. The next difference is, that I used the vertex group (FUZZ GROUP in your new screen shot) also for controlling the length of the particles. In this case the blue areas (with a zero weight) will result in zero length particles.

You really been nearly there. I’m curious. What happens if you use the vertex group in your setup for the length too?

Sorry blenderallday, our posts have crossed over. You are right, some extra loops around the eyes would also help.