Particle hair emission settings greyed out after particle edit

I tried Google but nothing apply to 2.8 and the Blender manual is not of any help on the issue.

Anyone can tell me what’s the catch here?

Thats perfectly normal. Having edited the particles, one usually doesn’t want to create a fresh set (which would be necessary after changing the emission parameters). You need to click ‘delete edit’ first (which does what it says) to be able to change settings again. See it as a safety feature,

Hi omgold,

I already try with delete edit but i thought there was a way after you style the hair a bit and you realize a hair clump is not the way you want that you could simply get back and tweak it while conserving the work already done.

Starting all over from scratch is not very productive. Also after delete edit and trying to get back in particle edit the hair vanish from the viewport but when i get back in object mode the hair show.

If you don’t have enough hair guides particle -> use Add brush.
If they are not enough long -> use Length brush.
If they don"t have enough segments -> use operator Rekey from particle menu.
If you disable Preserve Root Positions option in Options panel of particle mode, you can move selected particles at another place.

To sum-up, each setting of that panel has an equivalent in Particle Edit mode.

That is not supposed to happen. Maybe it is a refreshment problem. Does it reappear if you orbit the View ?
If it does not, you may encounter a bug.

Thank zeauro for the clear explanation and even orbiting the view and changing viewport method the hair don’t come back in particle edit but they do show up when i exit particle edit.

Well, the only logical reasons (I can think about) to see hair in object mode and nothing in Particle Edit mode are :

  • you disabled all overlays. (render only display)
  • In Particle Edit mode, you are not editing correct cache. You are editing cache of a cloth, softbody or Emitter particles or Hair Dynamics cache.

If it is not the case, you may be facing a bug.

1 Like

Thank for the clear explanation and i think it was because i hit the overlay button by accident.

The Rekey doesn’t seem to add more points to the particle, it adds them just outside the curve and doesn’t deform them in the same way as the one originally placed. I agree with polynut, not being able to change the number of points on the curve is painful.

That is because Path Steps displayed in Viewport is decoupled from hair segments.

If you increase hair segments by using Rekey, you also have to increase Path Steps value in Viewport Display subpanel of Options panel of Particle Edit mode.

When amount of Path Steps is sufficient, points are on hair curve.