Particle Hair from Meshes, Bezier Curves, Nurbs

Do not support bezier curve with bevel object ?
And any chance to once convert multiple curves or merge particle systems ?

Do not support bezier curve with bevel object ?

You can always convert a curve to a mesh (do this multiple times and join the meshes) and select the edge loops which shall be the root in edit mode, then use it as a hair guide for a particle system.

And any chance to once convert multiple curves or merge particle systems ?

Merging particle systems is possible but tedious. You can do so by converting different particle systems to meshes, join the meshes and convert the result back. Both conversions are done using the add-on.

Thanks for the reply,do you have an idea how to twist the generated hair guides ?

The easiest way is to use the bezier curve twist feature (select control point and press CTRL-T, IIRC). After wards, use the bezier curve as a guide directly or convert it to a mesh and use that as a guide.

This works only for bevel depth i.e round curve.But you can’t see the curve at the same time while you are playing with ctrl T,you have to convert to mesh to see the actual guides.

You can see the twist of bezier curves if you enable the normals in the viewport overlay like this:

Thanks,another problem came out https://blender.stackexchange.com/questions/213928/particle-hair-weird-look

Because all the hairs in a strand a perfectly parallel and aligned, you are experiencing a https://en.wikipedia.org/wiki/Moiré_pattern

Adding a tiny amount of uniform randomness (in the operator options of applying hair guides) should fix that.

1 Like

When I use the generated hair guides with hair dynamics,a few guides just won’t be affected by the simulation.Not sure if it has something to do with the addon.
Edit:definitely has something to do with the addon,I try a bezier curve on different objects using the addon and it’s completely unaffected by the simulation.

Well, the guides are only used once when generating the hair. They have no connection to the hair afterwards, so they are not affected by the simulation. For that you would need a modifier.

Which modifier do you mean,the simulation only affects hair guides.I meet another problem using this addon.My workflow is to use curve, convert to mesh and then convert to particle hair.To make life easier without trying to make the hair bevel shape orthonormal to surface in first few loops,sometimes I will put the the curve inside the surface a little , or just parallel to the surface.In each case after connecting the hair,the shape will differ from the original curve bevel shape.In the first case,I try to boolean with the surface mesh,but in many situations it’s just hard to keep vertex number of each curve in the bevel mesh (the intersection of hair mesh and the surface is not contained between 2 loops).I hope there would be an option to use mesh with different vertex number of each curve on it,first get the curves from the mesh,then use the maximal number vertex number to rekey these curves
and use the same fill volume function.
Or add functionality to cut hair guides inside the surface without affecting the shape before connecting hair would be nice.

I ended up using knife tool,spent hours to to cut the mesh inside the surface.