Particle instance modifier gives strange results

Hi there,

I have a feather model, which is used as a particle instance (With modifier) on a gryphon model. But some of the feathers are always rotated by 90 degrees. The other side of the model seems to have the same behavior, just inverted. Here’s a picture:

Here are my feather model’s modifier settings:

If I switch the axis to Z, the feathers that were ok become rotated and vice versa. This doesn’t seem to occur if I set the emitter in the particle system to “object” (instead of using the particle instance modifier). My particle settings aren’t special, just regular hair that I brushed into its current shape. The problem doesn’t go away when resetting the particle system (resetting the brushed hairs). I also tried playing with the “rotation” setting, but it doesn’t change anything. Any solutions? I really want to use the “Particle Instance” modifier because the feather model follows the hair curve, also it seems to render faster.

I hope someone knows a solution! :confused:


I did a quick test and everything looks fine for me
{The neck is a cylinder and the feather a squashed plane}
See the screen shot below.
Possibly the problem is some strange normals on the mesh of the neck?
Without seeing the blend there is nothing else I can suggest

Best of luck


I’ve also tried it with a regular cylinder before, but no luck. There are always some feathers that are facing the wrong direction. Even if it’s just a cylinder with a particle system and standard settings. I’ve noticed that on your screenshot, the feathers don’t seem evenly distributed as well, though this could be due to a variety of reasons.
I will upload my cylinder test .blend and maybe the gryphon file later, could you share your blend file as well? Maybe there’s some setting I missed. :slight_smile: Thanks for your time.


I kept the particle count low so it was easy to see the feather direction.
Here is an end view so you can see that the plane of the feather is always parallel to the emitting face
And the blend file is at the end.
{I did not actually save the other blend file, but it is quick to recreate}
One thing I noticed when I was recreating the file is that the mesh of the cylinder needs to have ‘slices’ otherwise the direction can be inverted for some of the feathers

Hope this helps


SupportFeatherParticles.blend (546 KB)

Thanks. I have no idea why sometimes it works and sometimes it doesn’t. Your blend file works for me…