particle instance texture issue

Hey, first post

I have an issue with the particle instance. I am modelling a bird and using particle instance for the tail. This is the only way I found to have Hair dynamics properly activated.

All works well, except the texture does not appear on the instances nor when rendered. I tired a test and got the same result. I have searched for a solution and haven’t found one.

Does anyone know how to fix this? I have uploaded the test scene if you need to see the problem. I have placed a reference plane with the feather texture in front to see if the texture renders properly.

Thanks for your help


TestFeatherInstance.blend (877 KB)

I believe you need to set Object in Particles Render section, not Path. Set Object to be feather. If you want to animate some bending in feathers, not sure, i tried Cloth with feathers pinned to plane. Kind of works.

Thanks for the reply.

The object feature with cloth or soft body doesn’t work for me. The way the feather deforms isn’t good (maybe my setting are wrong). Also it seems to deform in relation to the original object and not the individual feathers.

Thanks again.

one last thing, could the texture problem be a bug. Should I report it?

:frowning: not a slightest idea. I haven’t delved into animation and particles so deep yet but from what i read here, i don’t see textured objects involved at all.
For feathers i did use cloth Leather…

I had a quick look, but failed to identify the rendering problem yet. I had little tiem, I found some issues though with the particle syste, As it was said before you need to set it to object and refer to it as the feather item. Secondly you have to apply loc, and rot to your feather and set the origin of the feather to the base or it will never stick accordingly to your emmiter. Last You need to watch a tutorial about setting the materials for a particle system because I saw some innacuracies there too, including the alpha channel to the feather.
It takes time to set that up some times but its worth the while… just patience and research is your best friend along with all the helping people on this forum :slight_smile: