Particle Problems with a smokestack


I started off just doing the tutorial here this morning:

I got these results OK. Then I started trying to apply the info to making a smokestack and I ran into several problems:

  • Particles bleeding through the mesh. I checked the layers and normals and did a couple of “Recalc all” clicks after any changes. Now I think this may have been the halo size so I have reduced this and it seems mostly OK - still a tiny bit of bleedthrough. In the process of trying this and that to fix this first problem I applied the particle patch.
  • Wind appears to be affecting only half the particles during the bake. - See attached screenshot. The affected particles show up darker - perhaps 2 pixels in size - in the 3d window. Does anyone know what this indicates?
  • The half of the particles that are affected by the wind don’t get rendered. - See render attached.Can anyone help with any of these 3 issues? I will try to post a blend file.



We’re going to have to see the .blend, I’m afraid. Unless you have an Object set to DupliVert there should be no difference in the displayed size of the Particles. Also, the Strength setting on the Wind Object isn’t strong enough to reach the Particles (though you may have your Maxdist set so far it does affect them but I don’t see a dotted circle either). It looks like the thicker, windblown particles are comming from another Emitter Mesh that has an X-Force value affecting its particles, but it’s on an unrendered layer or the DupliVert Objects have their Material set transparent. All just guessing.


Hi Fligh,

Thanks for your quick reply! Here is a blend. It requires the particle patch.

I have deleted my emitters and created new ones. The new ones do not seems to have as many problems. I would still love to know if anyone can figure out why this one didn’t work…


That thing’s 10.6 MB, a bit heavy for 56k modem. Could you strip it down to just the particles and upload again please? I’ve already had to download the patched version just to look at it.



I am sorry. I don’t know why it was so huge. I only packed a single 112KB texture in it :eek: ??

Now it is 2.5MB with just the particles and the deflector.

It is very kind of you to download the patch!

I am going to start working with 2.43 RC2 (rather than going back to 2.42) so that more people have the same version.

Thanks so much… l3la

No luck. I’m using this build:

and as PranksteR wrote there it won’t open a file created with another version. You’ll have to tell me which version you’re using.


Shoot. For some foolish reason I used this old build.

If you want to give up now I understand!
I have quickly been re-checking your tips. So far no luck and I may just give up myself and re-do it either without any patches or with 2.43RC2. I would have to just focus on not getting halos bleeding through the mesh.


I downloaded that Blender version and the file kills Blender, even after downloading your file again. So seems I can’t help anyway. Maybe you should just get one of the newer versions and try again?



I downloaded RC2 just befroe RC3 came out and tried this file but RC2 deleted the particle systems - so it is pretty much like starting again anyway. Thanks again for trying to help - it would have been great if I could have learned from some mistakes there.

Yeah, I’m In The Same Quandary. I’ve Tried A Couple Of These Builds. Including Rc4 That I Found Yesterday. I Have Rc3 Installed. I Can’t Get Any Particle Deflection At All. I’ve Tried Dupliverting A Mesh To My Emitter. I’ve Tried Making The Meshes Actors In The Game Engine. I’ve Tried Simplified Non-shape-keyed Meshes. Will It Work In 2.42 I Dunno This Is The First Time I’ve Tried Deflectors With Particles. They Work Well With Softbodies. Did We Find A Bug?

2.34 Release Fixed All