Particle random rotation only randomizes 180 degrees?

(Blender 2.62) I’m using an Emitter particle system, with No Physics, to create and position vegetation. (It’s set to render particles as instances of a plant mesh object.) The Jittered distribution with Even Distribution turned off is working well for this – plants aren’t getting placed close enough to each other to intersect each other, which is good.

The problem I’m having is with the “Randomize rotation phase” setting. I want my plants to be randomly rotated around the up axis so they don’t all look the same. As I increase the Random setting for the rotation phase to its maximum value of 1, the resulting random rotations I’m getting only vary between 0 and 180 degrees, rather than the full 0 to 360 degree range.

This is quite visible in the rendered result because, for example, the largest leaf on my plant instances always points in a direction within 90 degrees of north for every plant, and never in a direction within 90 degrees of south.

Is this a bug? Or is there a better way to do what I’m trying to do?

(Edit: The workaround I initially described here works, but there’s a better technique described later in the thread.
I think I found a different way to get what I want, but it’s a bit complicated, and I’d like to find something simpler. I selected Boids Physics for the particle system and let the particles (plants) rotate themselves around randomly for a while and then freeze. I used these settings:

  • only allow the boids to move on Land
  • set Max Land Speed = 0 so the particles don’t move away from their initial “Jittered” positions
  • crank up the Max Land Angular Velocity
  • set Banking = 0 so they don’t wobble
  • set Height = 0 so they stay on the ground
  • just have one Rule in the Boid Brain section: Average Speed, with its Wander set to 1 which causes the particles to rotate around randomly.

Then set the particle Lifetime to something like 600 frames or so and set the system to render Died particles. Then run the animation. At the end of the 600 frame “warmup” period, the particles will be pretty randomly oriented and they’ll die and stop moving but they won’t disappear.)

I just had to deal with this issue myself in a recent video here:


What I ended up doing was to zero out the particle system rotation all together (do not use it). Then I added my single plant to a group. Then I duplicated the plant 5 time but left all duplicates on top of each other, at the world origin. Then I put each duplicate into edit mode and selected all the vertices. I rotated the entire mesh along the z-axis so each plant faced another direction. Then I set the particle system to use that group for my plant deployment. I also enabled Pick Randomly from the group for the particle system. So in the end I only had 5 different orientations for my plant but it was enough to give the illusion of randomness to the scene. You can, of course increase the duplicates for a more varied effect.

Perfect! I didn’t know about the Pick Random from Group option. That makes it easy. Thanks for your help! :slight_smile:

That’s a beautiful video. After watching it a few times I totally can’t tell that there are only 5 different orientations. The coloring of the water looks perfect too.

I’m playing around with your group idea and it looks like you can use the regular particle system rotation along with it to get some extra randomness, so only 2 duplicates should be needed. Also if I move the particle objects around in Object mode, the particle instances don’t move, so I don’t have to have all my particle models on top of each other, which makes it easier for editing.

And the Use Count option (under Render) lets me control the relative likelihood of creating the different meshes, which is awesome. Here’s a test with a single particle system object that creates 90% blue triangles and 10% orange quads, all randomly oriented, none of which intersect each other:

This is exactly what I was looking for for automatically placing vegetation. Thanks again!