Particle Scale With Age?

Hi All,

I have been re-visiting the billboard particle system hoping it could actually work.

Does anyone know how to make a particle scale smaller as it ages? Ideally it would scale to zero right before it dies so it does not just “bleep” off.


On your emitter, set a Particle Size IPO curve to go from 1.0 to 0.0 in the same length of time as the life of the particle.

I think this is where many go wrong… at least I did. Was going to make a tutorial because it seems to be a bit vaguely documented, but still planning.

The horizontal axis in IPO editor in patricle’s size parameter equals to percentage of particle’s age. So the curve must be drawn from 0 to 100, no matter what the age is. Of course it can be drawn from 0 to 50 or 0 to 150 but particles will still use the values only between 0 to 100. This works very well when using random age for particles.

I still don’t think that is going to work the way I want it to and I’ll just say it. I want my particles to work like 3DSMax or Maya.

Consider this scenario:
A single point emitter is traveling along a line from 0- 100 in the z-direction. It covers this range in 100 frames.
It is emitting particles with a life of 30.
I want the particles to start big (ie 100) and die small (0). So at frame 30 my first particle has a size of 0. But the new particle born has a size of 100. how can this be achieved with an IPO? It seems to me that this needs to be part of the particle system itself.

Also, I can not figure out how to insert a keyframe for particle value. I have my emitter selected, but when I use the I-KEY in the buttons panel, I get a non-particle related menu? I also opened up a IPO window and selected particles with the emitter selected. And while I can press the I-KEY, Blender does not actually insert a key. Nothing appears in the IPO window.

Ok, I need some practise on creating tutorials anyway, so, short particle system tutorial coming up!

If someone already helps you with this, the better, if not, wait for my reply. :smiley:

Thanks hhoffren, but I have read some other posts on the forum and discovered that, sadly, Blender can not do what I want it to do with particles. It is a shame, I’m not sure what the big particle re-write was about if not to address animatable parameters?

I will leave others with these links:

Also, what about this?

Hmm… I don’t know how I can understand your presentation so differently. I think it is possible to do what you described… and I’ve even used max over ten years. :stuck_out_tongue: Anyway, I’ll continue and finish the tutorial as soon as the encodings are done, since I’ve been planning to do this for some time already.

The links you gave are pretty old though, so maybe I still understood you correctly. We’ll see this later I guess. :slight_smile:


Maybe because of my quick pace, Blender crashed more than ever. Also, some audio didn’t go to the first encoded version. But finally, here it is:

Tell me how it works out.

edit: One more thing. The video is available in HD resolution, so use it if you can’t see what’s happening.

Great tutorial Hannu, works for me!


Olloppas hyvä! (You’re welcome! :))

I’d like to put this one on the tutorials section too, but I’m still getting blocked. Anyone know the exact amount of posts needed to not to get blocked? If it is secret, pm me? Won’t tell anyone, I promise. :smiley:


Thanks for the video, that helped me with how to create curves in the IPO window, however, I still see no change in the size of my point based particles using the curve system you describe.

I am attaching a BLEND file, if anyone has a chance to take a look.



ras_3d_stroke_1a.blend (232 KB)

Ah, you are using halos. If you enable “Size” button in particle visualization settings, you can see that the particle size is changing. But, I think it won’t affect the halo size. My guess is that the only way to create the desired effect is by textured billboards.


Thanks for pointing that out, however, billboards don’t work either. Even though I can view the particle size changing in the viewport, it does not render the size change for a particle with halo enabled (boo hoo).

As I write this I am trying different material settings, like turning off halo and using the default material, and it looks like you can’t render the size change, only preview it.

Anyone else have any luck with that?

Ah, I stand corrected, billboards DO work, it seems that once I disabled halo, the particle system would not let go of the material. I applied a new material and it started working.

GREAT TUTORIAL hhoffren!!! thanks for taking the time to create and share it. just what I was looking for

Glad to hear you all got the things working.


Halo size can be animated… as well can the color and alpha and so on. Only difference is that IPOs need to be edited on material IPOs instead of particle IPOs. It seems to be that billboards behave differently than points.

This came up on this thread: