Particle smoke doesn't follow moving object

Hi,

I want to make moving locomotive with smoke stack and particles smoke attached to it.

The problem is that particle object doesn’t want to follow smoke stack, always is going far behind. I have tried parent particle object to smoke stack or add I Loc key and animated separately but with exactly the same speed as locomotive has. I can’t fix it in both way. Any idea?

I would suggest starting a new scene and create a very simple version of your original scene. There could be conflicting settings that have accumulated after trial and error efforts.

  • animated cube for train
  • plane emitter with default particle settings
  • plane parented to cube

If that works, then there’s something going on with the settings in the original scene.

Hmmm actually I did already those steps as listed below. Instead cube I have an Empty and train is parented to it. Empty is animated. Plane emitter with defaults particle settings is parented to the same Empty. Is’t not working fine this way. I have tried to animated plane emitter separately (not parented to empty) and added the same speed and number of key-frames as an Empty has but result is the same, plane with particles follow train (or Empty) but a far behind.

Did you start a new scene to test this setup? My point is that there could be something else within the scene that’s effecting your results. Test a scene with just a cube and an emitter plane (no empty).

Yes, just made test with one cube and parented plane with default particles. Problem is that cube and plan for particles are both moving with the same speed but particles itself delayed. It’s look like they have smaller speed than plan and cube.

Try adjusting the velocity settings.

Also, check out this very helpful resource (‘Animated Guide’ to Blender Fluid Simulator, Soft Body System, and Particle System’s parameters):
http://www.pkblender.it/

I have changed many many things, read on page about particles and made animation from the beginning. Default cube and particle plane parented together work fine, particles follow plane exactly I need but I can’t repeat this with train animation. really don’t know how to fix it and it drives me mad.

Perhaps you could render particles seperately and combine in compositor?

Sounds interesting but I feel still a bit rookie in Blender and I don’t how to do that. Could you link me if is possible any tutorial?