Particle system with path follow

Hi all,
I’m not sure wether this is a bug or a wrong setup, but I’ve encountered the following problem:

I’m using a particle emitter that follows a curve. The problem is that the emitter only emits particles at locations at whole frame intervals, and not in between. Instead of creating a line of particles, it creates a dotted line. I hope this explains the problem well enough.

So, how should I let the emitter emit particles ‘in between frames’?

edit: sorry, wrong file . . . see next
(Im not able to delete attachment)

Attachments

test-distribution.blend (965 KB)

Try this:
For Curve under F9 setup “PathLen” 100
For Emitter under F7 (Particles) “Amount” 5 and “End” 50.
It will emitt 5 particles in 50 frames and emitter will finished curve path on frame 100.

(so If you need two particles per frame set amount particles 20 and end emitting 10)

Sometimes if you will see some strange particles behavior press “Free Casche” in Bake panel.
Or post your .blend

Attachments

test-distribution-2.blend (965 KB)

thanks for the help!

I attached the file with my particle settings added.

My emittor makes weird jumps, which was my problem.
Your setup doesn’t suffer from that. The difference is that I used Ctrl P > Follow Parent
and you used a Follow Constraint.
So your emitter was indeed what I was looking for. thanks!

I guess I’ll cross link in the Blood Cells solution which uses curve guides for particles.

http://blenderartists.org/forum/showthread.php?t=160251&highlight=blood+cells

@blackstorm: sorry I cant see your attached file, but for me Ctrl+P and Constraint works in the same way for me. I cant see differencies.