Particle system within particle system not showing up.

Hello all,

Yes, this is particle-ception. (with issues)

I put leaves on the bush using a particle system (Hair).
I then put the bushes on the ground using another particle system (hair).

The bushes that are placed on the land do not have leaves (shown in picture). How do I fix that without destructively applying the leaves to the bush?

Thanks for your time!

I was about to make a topic about the exact same problem this morning when I saw yours, so I join your topic (hope you don’t mind, I don’t intend to hijack your topic or something but any solution offered will probably work for the both of us). I too tried making plants (in my case, simple moss) by using an object as a particle hair emitter (with objects as hair) and then using a second particle hair system in order to distribute the complete plants on the floor. And in my case too, the leaves disappeared from the moss.

I thought, hey, I like particles! A lot! So why not abuse the randomness hair systems offer to make no 2 moss thingies look the same, right? To necro an old meme:

I hope someone has a solution for this, I mean, there’s GOTTA be a way to have particles emit other particles, right? I mean, people must need this all the time… explosion debris emitting smoke trails, fireworks, vegetation etc. Are we overlooking something really big?

Thanks for sharing a information.

Study this file particles_upon_particles.blend (838 KB) maybe it is what you want ?.

Density of leaves will be dependent on the trunk particle system.
More trunks less leaves per trunk (need to play with both particle systems emissions to get the look that you want )
Trunk and leaves have particle instance modifiers.

When I have done this, I set particle system on base object as object to the first item. Set particle system on the first item like hair (or leaves or whatever). It won’t show in 3d view, but will in render. What you will see is the object as you described. Don’t know if that helps or not.

Thank you for all of the responses! It looks like the “particle instance” modifier is the key. Now to figure out how to get everything to look right. I love your meme btw :D!

Yeah, solution works for me too! Thanks for the help! However, it seems to have some limitations, worst of all: random particle size doesn’t seem to work (at least not when I try to manage it from within the particle systems), so all instances of a particle get the same size. Is there a workaround for that too?

Quick try at particle-leaf-on-particle-plants:

You have to enable size in the “particle instance modifier” if you used that.
Then play with size and random size under Physics on the particle systems.

Awesome, that did the trick! :yes: Thnx