particles and curve

(_E2_) #1

Hello,

I’m beginner with blender and have question. I have curve. The curve is path for my object, that moves around screen and leaves particles. The main problem is that if curve makes turn, object goes not smooth with path, but when frame is changing object goes to next point in curve like in this picture (step like a straight line). How make lines not straight but like dotted red line in picture. It is possible to make particles near by curve without importing new frames?

Picture is attached (name: curve_and_particles.JPG)

Thanks for answers and sorry for bad English.

Attachments


0 Likes

(Fligh) #2

In the Particle Motion tab, increase the Keys value. If that doesn’t work upload your .blend so we can look at it.

%<

0 Likes

(_E2_) #3

Please download my file from this url:
http://e2.puslapiai.lt/curve_and_particles.blend

Different Keys values doesn’t work :frowning:

0 Likes

(Fligh) #4

The Speed IPO on “Curve_red” makes it jump thru those frames (31 to 50) so quickly that there is nothing for “Red” to do but draw particles in a straight line from frame to frame. If you can get rid of the Speed IPO you can set the DefResolU on Curve_red higher (about 50) and/or increase the PathLength.
I know it’s not what you want to hear but the alternative is rebuilding your Curve_red with the first 100 or so cv’s scrunched up into the first 50 frames and then using a Speed IPO to control how fast it goes from frame 1 to 100.

%<

0 Likes

(_E2_) #5

Thanks for answer, I know that if speed will be much slower there will be more new points in the curve and line will be smoother, but I can’t reduce speed. I can make speed lower and make curve with bigger path length and then edit this video with video tools (increasing speed like in first version), but rendering time will be very long. In this file is only two turns with this problem, therefore I can’t continue my work with next frames because in next frames turns will be also with high speed. Maybe is other solution to make footprint (footstep or watermark I don’t know exactly how to say in english) for real object when he moves? Like a motion blur in all directions where object turns? But i think the path will not change in other solutions too. Is it possible to make for example 1000 frames except of 500, but render only 1, 3, 5 and so on… frames.

0 Likes

(Fligh) #6

I don’t know of a way. Maybe change the framerate? If you press F10 twice it takes you to the Anim Settings where you can use MapOld/MapNew to have the particle emitter travel slow enough to avoid the straight-line problem, but render faster? Search “MapOld” here to find threads where I’ve explained how it works.

Another thing you might try is to scrap using particles and just have a small Sphere object with Glow or Radiosity, then use either MotionBlur or Nodes with VectorBlur to leave a trail. Talk to RamboBaby about VectorBlur, it’s probably the best solution.

%<

0 Likes

(_E2_) #7

Thanks,
I made 50 frames per second and made red point move 2 times slower. Then those fast turns I made a little bit wider. Now the scene looks better. Thanks for contact I will write to RamboBaby, maybe we will find new way to do that.

0 Likes