Particles and halo issue

Hello all. Im hoping someone can give me an idea as to what Im doing wrong here.

I have a flat plain with three particles systems.

P1 = basic short grass.

P2 = longer grass

P3 = dandelions. And this is where my trouble arises.

I have the dandelion modeled on a different layer. Its just a simple bezier curve with an ico sphere as the bulb. the material for the ico sphere is set to a simple halo.

If I activate the lights n camera layer along with the dandelion layer and just do a simple render the bulb looks okay (not perfect, still tweaking but still…). But if I activate the grass layer (with or without the dandelion layer) the bulbs never appear correctly. They always appear “behind” or maybe beneath is a better word, the grass particles, even if the actual dandelion particles are well “above”/“taller than” the grass particles.

Id really appreciate any advice on what I might be doing wrong.

I was gonna post the blend but its over the max file size.

Thanks for any help.

here is a quick render showing the issue Im seeing. It appears to be worse in the foreground.

Attachments


Hrmmm still no replies. Anyone at all have an idea as to why this is happening?

Are you using the strand renderer?
There are a lot of posts on grass. Even some amazing free work already done. Why don’t you issue some searches?

Don’t use halo, it is worthless.

Have you considers using the fiber script?
http://blenderartists.org/forum/showthread.php?t=160132&highlight=fiber

My Lux render of it:
http://blenderartists.org/forum/showthread.php?t=160142

Thanks Atom. So halo doesnt work well at all with particles? Hrmmm ok…

I ran into the same issue a while back. You can do one of two things:

  1. Stop using halos, they really are problematic, switch to billboards and texture them with something halo-like if thats what you need.
  2. If you really want halos, you will need to find the materials you are using for your ground, and your grass (basically anything thats blocking your halos) and enable Z-transparency on them. This will move your halos to the foreground but will probably create different problems/artifacts.

Hope it helps. Good luck!

It’s not that halo does not work well with particles, it’s that halos does not cast shadows or reflection. Halo is essentially a post render process and causes z-issues. What you want to use in it’s place are billboards as a visualization type, or simply create your own plane and use the object visualization type. Either of these solutions will appear in reflections and cast shadows. The billboard type has an added feature of facing another object (typically the camera). You can map a halo like texture to a billboard or plane.

Gotcha. Im here at work now where Im looking at the file.
Ill look into the billboards later. I guess the z issues you mention Atom are what I was seeing.

Azure: I didnt want ot respond till I had looked at the file but z trans was already turned on for the grass and ground textures. Did not solve my problem.

As I said Ill check out the billboards use later. My time on this project is cranking down.

Thanks for the assist.