particles don´t show when replacing datablock

updated: file enclose, I´m using version 2.49

scene 1: contains a mesh called globe, it has hair particles
scene 2: contains a mesh called cubetwo,
now, lets go to scene 2 and in the “ME” box replace “cubetwo” with “globe”.
do you see that the mesh changes, but the particle system attached to it does not accompany it anymore?


original text:

made a primitive looking character and put it in various scenes

then I made a copy of this ugly character and improved this copy by putting hair particles on it and by changing the mesh slightly

then I went to the old scenes to replace the old mesh/datablock with the new and betterlooking.

, but hey! the mesh changes show! but the particles don´t show !!! why???how do I fix this?

Attachments

artistsfile.blend (271 KB)

now, lets go to scene 2 and in the “ME” box replace “cubetwo” with “globe”.
do you see that the mesh changes, but the particle system attached to it does not accompany it anymore?

I tried this with file you posted, but nothing changed, not even the mesh. I also couldn’t recreate the other conditions in your post as it seems like there’s been a linking error somewhere.

You can just do a staright link between scenes and that will include the new object in other scenes but I’m not sure if that’s what you’re trying to do. So let’s see if we can figure this out with more information.

then I made a copy of this ugly character and improved this copy by putting hair particles on it and by changing the mesh slightly

then I went to the old scenes to replace the old mesh/datablock with the new and betterlooking.

, but hey! the mesh changes show! but the particles don´t show

I’m not sure about the sequence of your actions here. How did you make a copy? Did you do a SHIFT+D and then move it to another layer within the same scene?

Or did you add a new scene? What options did you pick if you made a new scene (e.g. Link Objects, Link ObData, Full Copy)?

thanks for taking the time to answer, I will produce a new file tomorrow which illustrate the problem more clearly…

I have tried the link to scene option you mentioned, and it works, but since my mesh will be attached to an armature and there will be a lot of scenes, this “fixing to armature” may be very time consuming.

In fact the problem is very simple. In the enclosed file, in scene 1 there is a sphere and a cube. The cube is partly covered by particles (through a vertex group)

Now what I simply want to do is to select the sphere and replace it with the cube, this is of course easily done, - however the particles do not follow, so how can I fix this is basically what I am asking about.

And why bother about this? what purpose does it serve in the real world?

well, I have this robot who is in a lot of scenes, his looks is very primitive, - now I have improved the mesh now he looks more human. Having made a better looking mesh, it was of course a piece of a cake to go through the scenes and change the name in the ME datablock box. So far so good, but I also discovered that the hair particles on the new mesh did not followt and that is what I am looking for a solution to

Attachments

artistsfile4.blend (382 KB)

Hmm, I’ve been playing around with this for a few hours but I haven’t found a suitable solution. The problem lies with the fact that modifiers act at an object level and the only way I know how to link at this level is when creating new scenes. If it’s in the same scene you can link objects through mesh data but that doesn’t help since the modifiers are applied at a higher datablock level.

The only ideas are came up with are not really elegant (they’re basically hackish workarounds) and may be completely impractical for you.

No 1:
Snap cursor to old model. Duplicate/link the good model and then Snap it to Cursor. Delete the old model.

No 2:
Instead of putting the new model into the old scene, can you put the old scene in with new the model? e.g. Have the new model in a new scene. From your old scene, select everything except the old model, link the selected items to the new scene (make them local if necessary).

No 3:
Change the mesh, as you’ve done, then copy the modifiers. E.g. In the latest file you uploaded, select the sphere, then select the cube. Press CTRL+C–>Modifiers (its at the bottom)–>Particle system

I’ll keep thinking about it, but for the moment I’ve run out of ideas. That doesn’t mean it can’t be done, I just don’t know how yet. :slight_smile:

@fade: thank you so much for spending time on this problem. I have tested out your 3 alternatives, and I thank that no.3 works perfectly well in my case! So I am very happy finally to have found a way out of this problem.
Thanks again very much :slight_smile:

No worries Jaqueline. Glad to help.