Particles insensitive to mist?

Argh. I’m this close to finishing my image when I run into troubles. Life jsut isn’t fair, is it? %|

Anyways, I’m making a waterfall that disapears into the distance, but the problem is that the particles don’t dissapear. Everythnig ElSE dissapears, the water, the bit of land I’ve got there, and it’s drvining me nuts becasue I can’t find out why.

I’ve tried using the unified renderer, I’ve made sure that the “no mist” button is unchecked on the material… so what the heck is going on?

If you look at the particles behind the falling boat, you can see that it cuts off at the camera’s clipping limit, but it doesn’t fade out.

Image:

http://img78.photobucket.com/albums/v346/RobMiller/Problem.jpg

http://img78.photobucket.com/albums/v346/RobMiller
/Problem.jpg

(no that’s not the final version of the particles, I tweaked it so it’d be easier to see)

Try turning the Unified Renderer on (in the Scene settings).

Martin

It just makes matters worse, and doesn’t fix the problem. :frowning:

Granted, I didn’t fiddle with any settings, so I don’t know if I can make this work properly or not.

Image:

http://img78.photobucket.com/albums/v346/RobMiller/Problem2.jpg

Edit
Though I am using 3.33, not 3.33a, so I don’t know if that’ll fix it or not, I’ll try installing the latest blender version tomorrow, I guess, see if that fixes it.

Nope, didn’t fix it (not that I really expected it to).

Here’s the blend file for anyone who wants to try it themselves:

http://www.anycities.com/user1/gnome/Images/Blender/The Edge.zip

(as with all free pages, you’ve gotta cut ‘n’ paste :-? )

the link doesn’t work here :frowning:

try posting the file without the space in the filename, also you could turn on ‘Shaded’ in the halo buttons and dim it so that it appears fainter in the render.

simon

:expressionless: Whoops.

<good link further down>

Yeah, I was thinking of just fixing it in a hackish way, either post processing it, or putting something infront of it that seems like fog.

404 on the link.

Martin

:x Grr… stupid crappy host.

http://www.anycities.com/user1/gnome/Images/Blender/Problem.html

THAT works.

The link cannot be saved blah blah…

You could just e-mail me the file, that should save us both some trouble :wink:

Martin

You definitely could solve the problem in post-processing and maybe that’s the overall best approach. You don’t seem to have any “competition” in the area where the fade-out needs to occur, so just “fix it in post.”

Maybe make the particle shaded?(sensitvie to light)

What you basically need here is a blurry-edged alpha mask that can be applied to the particle layer to cause the particles to become translucent in the areas where you want them to disappear. A tool like Gimp or Photoshop could create some nice, smooth gradients.

Then, apply that mask to the particles, and composite the modified particle-layer back into the picture. The techniques available are simplified by the fact that the particles, in this case, vanish into an opaque black region.

Now I’m pondering the available list of filters in standard Blender’s sequence-editor and trying to figure out how to accomplish that… using an image as a pure alpha map in SE. (Oh dear, I seem to be having a senior moment. %| Time for another espresso.)

Since water doesn’t glow naturally, I would suggest making them shaded even if you do find a better way to get them to fade away.

Yeah, as I said in the first post, those aren’t the final settings, but even when I get them to the settings I want, it’s still noticable.

They’re just that bright so it’s easier to see the error. :wink:

Thanks everyone for the suggestions, I guess I’ll just have to fix it by hand :-? .

the cog project shows how to create fading smoke in a downloadabe pdf

type cog project in google