particles problem...

hi, i dont know if this is the right place to post this but i’ll do it anyways,
i have some problems with some particles of mine…
as you see they are starting out well, and then they start spinning!:no:
anyone knows how to change this? so the particles will spread out normaly?
heres the blend file :

Try making the particles emit only from vertices (turn off FACES in the particle panel).

thanks! it worked!:wink: