Particles showing through objects

I am trying to learn blender. I have created a scene with a plane that is textured. I have added grass as particles to the plane and I then added a cube. The grass is showing through the cube. I have tried for hours to figure out how to stop the grass from showing though the cube. Its probably an easy solution, but I cant figure it out. Im brand new to this so that doesnt help either. Thank you for your help in advance.

Add images

You mean the parts poking out, not the gizmos right?

Your best bet is to select your plane, and go to weight paint mode (ctrl + tab in 3d view window, then mouse over weight paint)

and paint only on the faces/vertices you want the grass to appear. You may have to subdivide your plane a few times first before you can get this as accurate as you’d like. (select all in edit mode, right click in 3d view and click subdivide) or add some edge loops for maximal accuracy (in edit mode, ctrl+R, click then drag till the edge is where you want, then click to confirm.)

Once you’ve done this, you’ll have a new vertex group in your object data properties panel.

It’s worth noting, that you can skip the weight paint mode entirely if you so choose, and add in a vertex group here, and assign the weights manually using edit mode and the weight slider and assign/remove buttons in the object data properties panel.

After creating your vertex group, go to the particle settings, scroll down till you find the Vertex Groups section, open it up, and then select the group you’ve just made for Density.

Your particles will now only appear in the area determined by your vertex group.

If needed, adjust your vertex group weights till you no longer have glass intersecting with the cube.
You can also use this to rid yourself of any grass that wont be in the camera view, which will save resources, useful if you don’t have a high end computer.

I hope that helped. Let us know if you need more in depth explanation.

Thank you so much for the explanation. I thought it was going to be a hierarchy thing. I wish there was a different way to make particles avoid objects. I dont feel bad now for not figuring it out. I will try these steps and report back. Thank you again for your help!

1 Like

Glad I could help, there is actually another way I meant to include in my original reply, but forgot by the time I finished explaining the first way.

Go to the modifier tab, and click make instances real on the particle systems modifier.

Now you can select any particles you want and delete

Make sure to toggle off viewport and render view of the particle modifier if you do this, so that they aren’t doubling up still.

this should be done when you’re pretty happy with your particle system otherwise, since you’ll have to delete all of the placed particles and regenerate them if you decide to make changes. The fastest way to do that if you’re past the point of ctrl+Z would be to select it, then shift+L then select linked object data. make sure to deselect the ones that the particle system needs, you do not want to delete those.

This method might actually be better, since it gives you a lot more specific artistic control as opposed to the weight painting.

Hi Vahe, and welcome to b.a.
Have you looked at blenders Geometry Nodes yet? It is simple to set up a system with them that will use the cube itself to stop grass appearing near to it.
Go watch this video…

As you will see, the cube (or rocks in the video) can be moved around and the grass adapts automatically to its location. No need to do the weight painting.

Blender is heading towards being a lot more node based for its physical simulations - rather than a cluster of settings like in the particle system. So it is worth you learning this new method.

This uses a node called Raycast. You can also use a Geometry Proximity node or a Sample Nearest Surface node to do similar ‘is it close’ setups. So do search up more info on those two nodes.

You can also make your cube a colision object in physique tab and set it at particle killer.

Thank you for all the suggestions. Unfortunately, there was only one suggestion that worked for me. I think its because how I have built the scene to begin with. The only thing that worked out of all of them was painting weights. I was really hoping that the collisions would work but it did nothing when I killed the particles. I will try all the other suggestions in the future to see if it is because of how I built the particles to begin with.