Particles + shrink-wrap = not working as expected

Hi. I will try to describe the scene. Unfortunately I can not share it due to contractual reasons.

Hope is clear. I have a field. Basically a surface with a subtle displacement. On top of that field I have shrink-wrapped several meshes that work as particle emission. The idea is to populate a field with Solar Panel structures emitted from each of these meshes (hair particles).

The shrink-wrap used has this settings:

helpforum

The Particle system looks like this:

The issue:
The solar panels are oriented in weirds dispositions. They are placed correctly in terms of being fixed to the ground, but the rotation once they are shrink-wrapped looks quite funky.

If I tweak the orientation axis I get different outcomes. Non of them the one I am looking for: All the solar panels placed above the ground and looking to the same direction but still being affected by the height map of my ground.

Thank you and hope you can help me.

Did you try to apply the modifier. Once it’s wrapped why do you want to keep the modifier?

When you change the axis you need to take in account the rotation of your particle object. Normal tangent is not a good choice when you have normals pointing at many different directions if you want your particles to be vertically oriented.

Use the z axis and change your particle object rotation to match your needs.

Particle system with Z axis orientation:

Particle object must be rotated 90 degrees in Y axis.

Normal tangent orientation on particle system:

Not good at all.

Thank you ! but I am actually trying to achieve the “not good at all” :slight_smile:
I need each module of solar panels to be oriented accordingly to the average normal of the shrink-wrapped emission mesh. The issue with my mesh is that the Solar Panels have an orientation. The trees you posted as an example do not. I mean I have a front and a back…and the outcome I am getting is all messed up in terms where are they facing.

Thank you a lot

Well, then you want to keep the north south orientation of your particles.

Is this what you want?

I thought you wanted this:

I will send a sketch today! Thank you for helping me.

Here i found a ref picture:
image

My instanced object is a single module of Solar Panels. They need to be all parallel to each other as the picture. But my terrain is uneven. So each emittor its shrink-wrapped to the terrain. The outcome I am looking for are the solar panels to be oriented to the average normal of each emission plane wrapped to the un-eaven terrain. Always been parallel between rows and facing the same direction (sun).

When I am setting up my system the solar panels come almost ok, but some of them face the sun while others are just rotated randomly.

I can see it has to do with the shrinkwrap modifier…cause If I disable it the particle system shows all the PV (solar panels) facing in the correct direction.

Thank you

Now I understand what you need. This you will not make with particles but with duplifaces.

You need to wrap the mesh with the right amount of faces over your ground mesh and then apply the duplifaces.

This will keep the orientation of your object, it will not need to be rotated in the Y axis and the faces will distribute them accordingly. Like this:

To apply the duplifaces you will need to parent the object to be copied to the plane where you want it then go to “object properties” of the parent and under “instances” you set like this:

. After that you may hide the child object.

Thank you. I think I need to share how I prepare it to see if its possible to do this.
What is the main difference of duplifaces and the particles approach?

The duplifaces forces the object to be placed on specific points accordingly to the number of faces of the parent object.

PS: I forgot that there’s a way to control the positions of the particles that is to emit from vertices.
Now I’ve found what you are saying. Really, some of the pannels rotate a bit in strange ways.

Sadly, the same occurs with the duplifaces, so instead of both, you should set the system to vertices and not to faces. Dupliverts works perfectly.

Really, the only way to keep the orientation perfectly aligned is the dupliverts:


Duplifaces did not have a better result than particles.

But really, try to change the normal tangent orientation to Global or object Z axis. The result is the same as in dupliverts. I am trying to reproduce what you asked keeping the orientation because you said it was necessary but in my case I see that the problem is because of that orientation set and not because of the wrap.

Hi ! Thank you for such a thorough work you are doing to help. I did set the orientation to global Z…but then the solar panels go through the displaced terrain in some parts…
I will need to make a dumb scene and share to see what I mean.

Ok, but when they mount the panels don’t they adjust the support to keep the panels on the “horizontal” position in relation to the ground. (this, of course, discounting the inclination they have.)

Cause I thought that the main goal of those panels was to be oriented towards the sun and not in relation to the ground.

I don’t know, I always thought it was something like this:

I think you are getting it right. It might be you already provided me with the answer. I have the files at work. I will take a look tomorrow. Thank you!

1 Like