Particles stop at frame 200?

Hi,

Edit: title is a mistake–particles keep going, smoke stops.

I’m trying to set upa particle system that will emit smoke from a plane that’s following a tracked null. Because I want it to match up with the tracking footage, I’ve set the particles to run from roughly frame 65 to frame 850. The problem is that the smoke stops working at frame 200, even though I’ve set the particles to emit for longer. In fact, some experimentation shows that the smoke gets weird any time the start frame isn’t actually 1. Am I missing something, or is this a bug? I’m attaching the file for review, if anybody would care to take a look.
Thanks!

Attachments

Smoke_No_Work.blend (6.39 MB)

Select your domain object, go to the physics tab look for Smoke Chache.
Set the smoke start and end settings to match the particles and bake.

Thank you! (slaps forehead)