Parts of my model don't move with armature

I am working with a mesh I brought in from meshroom that’s been given a few boolean modifiers to make solid. When I try to bend it with an armature, some vertices stay in their original positions. It is parented with automatic weights. I tried weight painting it all blue, similar result. The attached image is before/after the attempt to rotate one of the bones. Any idea of what I’m doing wrong would be great, thanks!

Hey, Your bones are too short for your mesh - they should be at least its length. Painting them ‘Blue’ does include them but its ‘0’ weight.

Thanks for info! I tried making the bones go the length of the mesh, but the problem remained. I should have mentioned that I was able to bend it normally before I cut that triangle shape out of the bottom to save material on the 3d print. So I am assuming there is something wrong with my model, I just don’t know what it is.’

Hey, Anytime you modify the bones, you MUST un-parent the mesh object first - make the modifications then re-parent it. Since you modified your mesh with removing part, that messed things up also. If you plan to 3D print this , there should be an add-on to aid with that, look in the user preference - add on

Thanks. These are actually different blender sessions. The screen cap of the bones functioning properly is from a blender file from a few days before. When I decided to print it, I started over with the same origin stl file (maybe it would have been better to save as a obj?), carved out the hollow area to avoid wasting material, then added the bones.