Parts of sculpt gets negative(?)

So recently when I’m sculpting I came across this weird problem where it seems like part of the mesh has flipped normals or something.

Tried several times to flip them back, even though the normals look good in edit mode.

Simply shown in the image were I just took a brush on “add”, and it kind of switches to subract.

Anyone know what it is/how to fix is?

Attachments


You appear to have forgotten to attach the blend file to your post.

http://www.pasteall.org/blend/13171

Anyone? Really need help with this :frowning:

First off… Turn off ‘Double Sided’ in the ‘Object Data’ Tab… It’s between the ‘Modifier’ tab and the ‘Material’ Tab.
Icon looks like an upside down triangle. The option is under ‘Normals’.
You’ll be able to handle more polys and sculpting will be MUCH smoother.

Your problem is that many of your normals are inverted. Tun on Face Normals in the Mesh Display section of the properties panel [keystroke ‘N’] and you’ll see that all of the normals on the right belt are facing into the mesh. There are some edge polys that face inward as well.

For whatever reason, ‘Make Normals Consistent’ (ctrl+n in edit mode) doesn’t solve the problem.

Here’s how to fix it:

In Sculpt Mode, decrease PREVIEW subdivisions to 0 in the Multires modifier.
Go in to Edit mode, turn on Display Face Normals. It’s in the Properties panel (N key in 3D view) under ‘Mesh Display’ section.
Those little lines show you the direction of the normals. They should all be facing outward.

It may look confusing with all those lines, so select the top loop of polys and hide them (H key).
You’ll see that the polys underneath point straight up into the geometry. This is no good. They need to point out from the interior.

Select the offending polys and flip them using Ctrl+f and 1st option Flip Normals, or the button in the toolbar, ‘Flip Direction’ might be faster.

Your going to have to hide polys, examine normals, flip as needed, unhide (Alt+H), repeat.

Luckily this mesh is at its base very low poly, so it shouldn’t take too long to go through. You did remember to set Preview subdivisions to 0, didn’t you?

Thank you very much for, not only your response, but also for the level of detail it is.

Now unfortunately it didn’t work :frowning: or I guess it works to some extent, because if I only use very small brushes it works just fine. But bigger ones makes the sculpt inverted/negative, plus I got some weird shading after flipping those who needed to be flipped.

Made a quick little video showing you what I mean.

If you attach your latest blend file, I can take a looksee and maybe we can figure it out.

Absolutely! Here’s the exact file that I used in the video

http://www.pasteall.org/blend/13230

I had this exact same problem about a month ago. Took me two days to solve it. Simply apply the scale and rotation of your object and it will sculpt as you would expect it to.

2 Likes

Got it sorted. Intersecting polygons.
You see those oddly drawn rectangles… That’s where the polys underneath are so close that they actually passing through the polys on top.


You have to tweak the polys.
If you hold down the Shift key you can get finer control over your move.

Or… Better method.
Switch your Transform Orientation to ‘Normal’ ( already done in the blend file supplied )
Hit G to grab and immediately, without moving the mouse or clicking, double tap ‘Z’ to move along ‘Normal Z’
You’ll see the direction that you’ll be moving in. If that is not the desired direction, double tap ‘X’ or ‘Y’ to change it.

Now instead of using the mouse, type ‘.01’ to tweak .01 units along Z Normal.

You can do this on both the top and underside to separate you meshes slightly.

Oh… and turn on ‘Front Facing Only’ in your Brush settings

Okay after I tweaked the polys I was still encountering the oddness…

Here’s what I did that fixed everything…

Cap the open ends.
Go in to ‘Edge’ select mode and select the 2 long edges at the ends of the belt(s) and hit ‘F’ to make a face between them.
You’ll have the two small openings on either side, so zoom in and ‘F’ to make a faces to cap these holes too.
Repeat for the other 3 open ends. Now ‘Make Normals Consistent’ will work. Ctrl+n in Edit mode to do that.

There is still strangeness when in sculpt mode, so I can only surmise that the Mesh Data has been corrupted, OR something to do with the VBOs / cached data is out of whack. We’re gonna have to get Blender to rebuild the mesh data.

Remove the Multiresolution modifier.
Go to Object Mode
Ctrl+A to and apply rotation and scale.
Alt+C and select second option ‘Mesh from Curve/Surf/Text…’ to rebuild the mesh data.

Now you should have a clean mesh to add your multiresolution modifier and start sculpting it.

That’s what worked for me.

P.S.
Ya know what… I don’t actually know if Alt+C rebuilds the mesh data, or if Ctrl+A took care of it.
I did not test them individually, but the end result is a clean mesh.

Thank you very very much! Now it works as it should :slight_smile:

Thanks, that did it…