Patchy/Incomplete Blur in Compositor?

In Blender 2.71, I am trying to use the Blur compositing node to make some blue emitting lines have a glow around them.

Here is the render without the blur:

This is what I am getting:

This is what I want (blur done in GIMP):

So what is going on? It honestly looks like the Blur isn’t sampling every pixel of the rendered image and is skipping large chunks. Is there any way to fix this?

Oddly, the cycles autorendered image does it correctly. Just not when I click the Render or Animate buttons.

I’m actually using 3 Blur nodes, combining them with Add nodes. The three nodes have, for their X and Y, 10, 15, and 20.

I’ve tried all the other types of blurs beside Gaussian that are available in the drop-down. I’ve tried clicking all the check-boxes in the node. I’ve tried reducing the Image Size. Every attempt has had some form of patchy blur.

I did discover that if I increase the image resolution to 4 times that of normal HDV resolution, I can almost make the patchiness go away, at the expense of taking a very long time to render.

Changing the resolution from HDV (1440x1080 4x3) to HDTV (1920x1080 1x1 aspect ratio) only succeeded in moving the patchiness around, not eliminating it.

I’ve also tried changing the “Chunks” under “Performance” in the Node View to 32x32. That didn’t help either.

It has been suggested that I try adjusting some render settings. Under “Performance” in the Node View, I’ve tried both checking and unchecking "OpenCL and “Two Pass” (separately). In the preferences, under “Compute Device”, I’ve tried both “None - CPU” and “CUDA - GeForce 8500 GT”. In the Render tab, under “Render”, I’ve tried “CPU” and “GPU Compute”. Everything ends up with the same result, unless I use “CUDA - GeForce 8500 GT” in the preferences and “GPU Compute” in the Render tab. That particular combo gives me nothing at all - it doesn’t render.

Honestly, I fail to see how adjusting render settings would affect the blur. The rendered image comes out fine. It is how Blender is blurring the rendered image that I’m having trouble with.

Did you turn on Gamma in the blur node?

Yes, but it still has the same problem.

                  I found the solution! It was the Anti-Alias setting on the ID-Mask  node that was causing the problem. Apparently it was causing the render  of those thin lines to be patchy, resulting in a patchy blur. Once I  turned off the Anti-Alias, everything was fine!