Path Length Does Not Work in 2.44

Hi All,

Reset Blender
Create a path object
Add a path constraint to the cube
Type the name of the path, typically “Curve” into the OB field of the path constraint.
ALT-A
The cube follows the path.
Add a timeline to the interface so you can scrub the animation.
Select the path and press F9.
Change the Path Len from 100 to 300.
Scrub the timeline and the cube stops moving at 100 frames even though the path length is now 300 frames.
This is wrong it should go 300 frames.:ba:

Keep the scene open and add a Bezier Curve, press F9 and turn it into a path by pressing the CurvePath button.
Select the cube and copy/paste or type in the name of this new curve into the cube constraint so the cube is following the BezierCurve path.
Scrub the timeline and it moves 100 frames.
Select the BezierCurve again and press F9
Type 300 in the PathLen field and scrub the timeline.
The cube now moves 300 frames like it should.

What gives, is the path object just broken?:spin:

you might have a ‘Time’ IPO for your path curve that is overriding the ‘PathLength’ parameter

I just discovered that, thanks.

It looks like that is the difference between the “path” and “curve”.

If you use the path object, blender automatically create a time IPO with a length set to 100 that you have to edit in the IPO window. When you create a curve, Blender does not do this.

I’m starting to get the hang of this…

I wasted half a hour looking for the automatically created curve, so I’d save the time for others:
In the IPO window header, click the “Object” dropdown and choose “Curve”.
Another good and useless deed done.:yes: