PBR textures not applied when export to GLB

Hi,

I made simple 3d model and put texture.

in Blender it looks like screenshot below.

but when i export GLB file and open using 3d viewer, it looks like screenshot below.

https://i.imgur.com/yikAq5C.jpg

I dont know what is the problem or i missed somthing.

node screenshot

https://i.imgur.com/gjBQ3Ys.jpg

Please let me know how do i fix this.

Thank you.

One thing right off the bat is you need to change the Normal, Roughness and displacement to Non-Color data…always change that for anything that does not add color to your objects…besides that, I think your GLB screenshot is better than the Blender screen…of course, you have to realize the 3d viewer uses different lighting set up then Blender so that makes a big difference, so I am not sure what you were expecting it to look like.

The displacement texture will not currently export to glTF/GLB, you can track discussion and progress on that in KhronosGroup/glTF#948. Other than that I agree it probably comes down to lighting and using “Non-Color” data. Most viewers will give you some different lighting and/or tone-mapping options.

Hi

This issue is exactly correct that you said.

DIsplacement map is not applied.

I will check other method that i will try to find alternative method.

Thank you.

Hi,

I didn’t know if I had to change maps to Non-color data.

And i have made the changes.

Thanks for the helpful advice!