PC issues - Can't connect to network - Please help!


Figured I’d post my issue here because Blender users are pretty tech savvy people.

I’m at my wits ends. I’m unable to connect any browser to the web and keep getting the below errors (be it Chrome, Firefox, or Edge).


I took my system to Micro Center, and everything checked out. They were able to connect it to their wi-fi, no problem.

I tried researching more fixes. Here’s what I’ve done so far.

  • Hardwired directly
  • Reset PC and router
  • Reset network settings
  • Reset adapter card
  • Command prompt - flush DNS, winsock reset
  • Turned off firewall
  • Cleared browser cache and data

Another thing is, all my other devices are connected and running fine! The issue lies strictly between the browsers on my custom build PC and the www. I’m running Windows 10, and it’s a decently fast system (Intel 7, RTX graphics card, etc.)

Around the time I was having these issues I uninstalled Webroot anitvirus, only because I let my subscription lapse and I wanted to temporarily disable it.

So, I have no idea what to do now. It was suggested to me to reinstall the OP, but I really don’t see how that can fix the issue. Especially seeing that the repair center had no issues with connectivity.

I would appreciate any suggestions!


is the clock sync’d? sometimes that prevents things form connecting. can you ping a dns like

but tbh reinstalling windows is a good thing to do. just to sure you dont have a virus. if you are “in the market” for an AV, ive been using avast for a while with no issues or false positives and free feature set is good (there is some extra things you dont need but you can minimal install). they recently made the firewall free and that is so much better than windows. (just sure to have windows firewall on when you enable avast one or xbox features break.)

i just noticed you said “network card”, most mobos have an integrated card. you should use that.

So you have internet connection just the browsers dont work anymore?
Maybe the uninstalled antivirus has messed up browser settings, try reinstall them or install another browser to check it.

You can also try reset browser to factory settings.

Thank you for your reply!

Correct. Internet connection is good. And I successfully pinged numeric addresses.

I spoke to a couple others, and here’s what we’re thinking. After uninstalling Webroot, it left the browser extensions behind. I reinstalled Webroot then unchecked “Activate browser extensions”.

I’m at my friends house, and everything is working fine, which was how I’m now able to re-download Webroot and reinstall it. Such a pain. I’ll know if this works once I get back home.

I’m hoping this resolves everything. Webroot owes me money and lost time dammit.

Thanks again!

Thanks for your reply.

Yep, clock is synced. I was able to ping numerics, but not www addresses.

And yeah, I was trying to use a scalpel vs. a sledgehammer by not having to reinstall the op. Gonna be my last last last last resort. :slight_smile:

Thank you!

Hi Pottsie,

Have you checked the ip settings on your Win 10 PC? Go to Control Panel > All Control Panel Settings > Network Connections. Do you see anything odd or wrong? Right click on your connected network device. Here you can check the “Status”? There’s also a Diagnose option too which sometimes actually works (although really depends on the issue). Status dialog will let you see the ip address, dns server, etc… which should typically point and match what your router is setup for. I’ll assume your router is the DHCP server and provides the DNS server defaults also.

The connection details should match the same network details as your other devices. With the IP address being unique for each device on your network. A duplicate IP will give you all sorts of connection issues.

Selecting Properties will get you to the protocols that are installed. Check the Internet Protocol Version 4 (TCP/IPv4) propeties. Are they set for automatic IP & DNS (which is the typical setup). Maybe your antivirus changed some of these settings but didn’t reset after being un-installed.

Also, on a side note, wondering if your username is a Happy Days reference!

Good luck and stay safe!

Hi! Thanks for your reply.

To answer your last question first, it’s more or less from Happy Days:) Just a nickname based off my last name. haha

Thanks for your suggestions. I tried every imaginable fix. I took my computer to a couple different locations, and the connectivity works just fine. All browsers work, and are fast.

It has to do with my location. I actually redownloaded Webroot and disabled the browser extensions. Still the same old issues.

I’m officially at a loss. I ping’d google and a couple other addresses. Came back fine. All packets returned. I tried a tracert command. And that’s where it seems to be tied up, somehow.

Hi Pottsie,

Sounds like you’re using a wireless setup. Have you tried wired? Screenshots might help to.

Oh yes. I hardwired it in. Same issues. Can’t do screenshots. I’m on a work issued laptop and it has admin restrictions. Otherwise I’d attempt to screenshot from my desktop, and transfer to this laptop. So that’s a no go.

I’m not sure how else to explain my issue. Again, I have connectivity. I can ping. It’s connected. Something is blocking the browsers. I don’t know how to uninstall the browsers then reinstall without being connected. I just tried uninstalling the network adapter and reinstalling. nothing.

My fear is that if I reinstall the OP, I’ll still have the same issues. Is having a corrupted IP a thing? I don’t know. I can connect elsewhere just fine. The browsers work, the sun shines, bunnies are hopping through the fields. But now, in my home, it’s cold and desolate and surrounded by dementors and no connection. I’m at a loss and drinking a bottle of wine.

You haven’t reinstalled the browsers yet?
Get it downloaded from another source, and reinstall from an cd, usb,…
You can also try use your handy connection just for checking it is not your router.