Performance Issues

Whats up guys, i’m a newb, hehe. Been using blender on and off for about 6 months. Here is my problem: I just bought a new comp, AMD Athlon 64, 1Gig RAM, 250Gig HD 7200RPM but when I run blender in editing mode it runs kind of slow. I’ve never had this problem before. I’ve updated my drivers for my graphics card, oh yeah , thats an ATI Radeon Xpress 200, integrated 256mb. Any thoughts on why it would be running slow in edit mode? I’ve only been trying to add text.

To give you an idea of how slow it runs, it takes about 1 second to click on anything or add anything to the project. Usually, on my other comps, even my laptop, this was pretty much instantaneous. Thanks for the feedback.

Hello Ranger84!

Welcome to Elysiun!

Are you using windows or linux?

I have about the same computer as you do and have no problem at all . The problem probably lies in your configuration. I use Linux and it is smooth as it can be.

If you are running windows, you might want to check which other services/program are running, which could slow down Blender.
As of a general experience on both windows and Linux, Blender was always faster on Linux for me. But this is a common debate here.

Please let us know what OS you are using.



My bad, its XP Media Center Edition. My laptop runs blender smoother than this comp but the render time is longer. Never had a problem with blender until this one, been kinda thinking its the Media Center Edition of XP, not sure what the difference is in this and regular XP though. Kind of frustrating at times, hehe. Thanks for the help!!

Hmm… I never tried XP Media Center but I believe they have not yet released a 64 bit edition.
Since you have a 64 cpu, it might decrease some performance because of software/hardware imcompatibility or misusage.

If you want to have better compatibility on that level you should be using Windows XP Professional x64 Edition.
Alternatively, if you are into Linux, you might want to try a 64 bit compatible version. You find the compatible versions here (simply pick choose 64 bits in the platform drop down menu and start the search).
I personnally use Fedora Core 4 and it works great.
This is a hard way decision however since it involves replacing your OS but sometime it is worth the effort.

Also, as a reference, you can take a look at Blender’s benchmark page here.

Hope this helps,


I think its the ATI driver problem.

the 64 bit shouldn’t be the problem, all you loosing thier is not running the pc at it’s max, it should still work fine for 32 bit

are you using zone alarm, it’s been give some hasels with the latest up date. try turning it off if you are.

if it gets slower as you use it more then this is the “ati bug” there are a bunch of annoying fixes [like older dlls and stuff], I’ll let you find them yourself [on this forum]

My guess is the ATI drivers. It also could be an openGL issue - When running on a Mac, no OpenGL/Aqua elements can be on top. Similar in Windows - I use stardock on my work PC (p4 3.0 HT with 1GB ram and ATI integrated) - I have to resize my blender window so that nothing else is (or can be) drawn on top of it. I also use GKRELLM on winXP pro. It also cannot lie on top or blender.

It’s definitely not your hardware. I use blender on a PII 333 with 32 mb nvidia card - UI is quick and responsive (win98 and Mandrake linux).

Good luck.

Ok. Please disregard my foolish absession over the OS problems :smiley:
It is probably the ATI bug indeed (now that I read more about it, It seems to make more sense).
My judgement was based on personal experience with windows 2003 server (the early new-born status versions) not running well on multiple cpu servers because of cpu management inadequacies.

deep apoligies and me lying on the carpet praising other’s better knowledge :smiley:



Thanks for the responses! I’ve tried the ATI driver dll solution prior to posting. I had 2 problems with that:

  1. I couldn’t find the driver they suggested using on ATI’s website.

  2. When I did the command in command prompt expand atioglxx.dl_atioglxx.dll, it gave me a message that said no destination path specifed for expand atioglxx.dl_atioglxx.dll

I’m sure this is just me being the noob as far as windows command prompt commands so any advice on that would be great. Once again, thanks for the help!! :smiley:

Alrighty then…I still cant find any of the older ATI drivers that were recommended to fix this problem. If anyone has any info on where I can get those .dll files from, please let me know. I’m pretty certain that it is the ATI bug at this point. It definitely slows down as I try to keep working. Can anyone tell me if the current video card I have integrated into the comp is better than the one I may put in until I can get a PCIE card?

In the comp: ATI Radeon Xpress 200 256Mb (Integrated)
Might put in: Nvidia GeForce FX 5500 OC PCI 256Mb

Video issues seem a whole lot more probable to me than any global operating-system issue, even on a Win-doze machine; even on a hobbled edition. Some kind of timeout, perhaps, or a hardware problem where the device keeps trying to “re-try.” Glitched-up memory on the card. Stuff like that. Any other devices or apps having problems?

I have the exact computer as Ranger, with the same problem. I also started the same exact topic No one could help. Ranger the only thing that I think will work is getting a new graphics card that supports opengl. I even e-mailed ATI. Ranger we’re both screwed.

Another noob here, I have a labtop with XP and ATI 200m (128mb) and I am also having the same problem as described above. :frowning:

EDIT: I just was looking through the ATI CC and under “3d” i clicked OpenGL and then “compatibility” and their is an option that says “force z-buffer depth”, the options are “force 24-bit”, “force 16-bit” or “disabled”, it was set to disabled, I changed it to “force 24-bit” and the problem seems to be solved. I dont Know what a z-buffer is and i really had no clue what i was doing, I dont know if this would work for you.Also, Im not sure if the standard ATI Control Center has these options, I have the Omega ATI drivers (google it) and I think the CC is different. :smiley: