persp and ortho

I use num pad 1, 3, 7 I do not change num pad 5 I do not change from ortho. Sometimes when I look up it has changed to persp but I do not know how or why. Any ideas how I am doing this? I do not remember this problem in 2.4 I have removed the caps lock and the windows key Do I need to pull out num 5 ( just a joke, I’m not pressing mun pad 5 something else is changing it )
Thank you

Perhaps you have Auto Perspective enabled?

In 2.4x I would go into Camera mode, and when I MMB’d away, I’d be in Perspective mode.
But 2.59 doesn’t do that.

Whenever I find Blender acting “weird”, I “Load factory settings” and try to repeat it. That just rules
out a bunch of stuff quick.

Best of luck!

Thanks for the help. I try to make it happen and it wont. I think I just need to watch closely to see what I’m pushing. It really bothers me.
UncleGummey very interesting I did not have this problem in 2.49
Thanks all for the help

As Fweeb stated before you managed to set on Auto Perspective : Switch automatically between Orthographic and Perspective view, when you are using Top/Side/Front view, or user view. When disabled, Top/Side/Front views will retain Orthographic or Perspective view (whichever was active at the time of switching to that view).
Link to the 2.5 manual page