"Phantom" face

Hey everybody! I am very new to blender, and I am creating a boat hull, and I have encountered an issue that I cannot seem to fix. I have looked for hours to find a solution, nothing has worked. Basically there is a face that keeps connecting to random vertices I don’t want it to and I can’t get rid of it and I can’t see how it is happening. I have provided an image for you, top image shows where it is and bottom is the raw photo. Anybody have a solution?

image

In face mode, deselect all, go Select -> All By Trait -> Faces By Sides. In the options on the bottom left pick number of vertices 4 and mode “Greater Than”. Deselect everything you want to keep, delete the rest.

Be wary of concave n-gons while modeling, they might produce undesirable results. When they do, either split them manually (with e.g. knife tool) or delete them and build the faces as quads.

Thank you!