Phantom vertex after boolean modifier

I’m doing BlenderGuru’s anvil tutorial to re-learn Blender after not using it for almost two years. After doing boolean modifier to remove part of the original mesh, he corrects some ngons to be quads, which I also do. After he does it, in face mode a vertex he previous has showing disappears, whereas mine will not go away. The only thing I do differently (because I’m in 2.79 and he’s using a 2.78 version) is when doing the boolean modifier I have to change the modifier variable BMesh to Carve, otherwise it doesn’t interact with the mesh I’m trying to adjust. I’m pretty much at a loss at this point.

Mine and his after correcting ngons (all faces definitely have 4 vertices now):


Mine right after correcting ngons applying subsurface modifier (takes into account the phantom vertex):


His after applying subsurf modifier:

There’s a little icon at the bottom of the 3D view in edit mode that looks like arrows facing each other. It’s for auto-merge. Enable it, and when you snap vertices to each other, they will weld without having to take an additional step. Otherwise you can try selecting the parts that currently overlap and use remove doubles. (W for specials menu followed by R.)

At least I think that’s what you’re needing.

I don’t believe you. An n-gon face at the bottom would put a face indicator right about there.

The cropshots don’t show feedback from the interface, and there’s no file to actually check if it’s that or something else, so it’s just a guess

I agree that it looks like the bottom of the mesh features an n-gon. In fact the derived subD mesh very clearly points to that. OP should make sure that the face is deleted instead of hidden or if inclined to keep the mesh manifold just select the bottom n-gon and inset it(i-key). Bonus points for creasing the inner loop in the resulting structure.

edit: Alternatively OP might have accidentally created the n-gon out of the edges in half circle formation. Since the face normal would be pointing away from the view the screenshot is taken it would appear invisible.

It ended up being the face on the bottom of the mesh. I honestly don’t know why that could cause it to do what it did, but after removing it, it fixed itself. That step wasn’t in the tutorial either, so I doubt I’ll be the last to have that question. Appreciate all the feedback!

I’ve had similar problems. I simply deleted them singly or in groups.
Sorry, I don’t know the cause.

It’s not a problem on itself, it’s just a face indicator when in face select mode. The reason is that the face indicator is in the middle of the face, and when the face is concave, it’s outside the face shape. Concave polygons can create problems because of triangulation https://blenderartists.org/forum/showthread.php?337775-Simple-modeling-question-Triangle-stays-when-moving-vertices&p=2653061&viewfull=1#post2653061


Bottom right:
A concave n-gon has its face indicator outside the face shape because that’s the median point of all the vertices.

Making all polygons convex ensures the triangulation doesn’t have an option which would go outside the existing edges. N-gons, concave or convex, can distort in a normal UV unwrap, which is one of the reasons they’re left in a model in strict cases.